Click through on inactive windows not working! + Mouse Acceleration.. WTF!

Discussion in 'macOS' started by binbs, Aug 29, 2010.

  1. binbs macrumors newbie

    Joined:
    Apr 19, 2010
    #1
    Hey guys.

    I recently purchased a MBP and am really enjoying using it. However I have a few issues that I have to get taken care of or I will prolly end up going back to windows.

    First major issue is that I have to click twice on mostly everything. If im in a different window and want to click on a link in the browser I have to click twice.

    Im also playing poker on a poker client that uses Adobe Air to run. Here when Im playing on two tables at once, and go to one table to press a button like Raise/fold etc, I have to click twice. Once to activate the window and once to click the actual button. In windows I only have to click once!

    This is very annoying especially when using a trackpad. Ive upgraded my X11 to XQuartz and selected the "Click through inactive windows" option but it still doesnt work.

    If anyone could help me with this issue this would mean a lot. Thanks.

    P.S. Also have another issue that I hate the mouse acceleration and am dumbfounded that Apple dont have an option in Snow Leopard to turn this **** off!! I've googled about this as well and found out that theres some 3rd party applications that can be used to semi-solve this issue.

    Is there any update on how to turn mouse acceleration off completely? I obv dont want to turn it off for the trackpad as its pretty useful there =)

    Anyway, thanks for taking the time to read my post and hope someone out there can help.
     
  2. LPZ macrumors 65816

    Joined:
    Jul 11, 2006
    #2
    That does work (just tested with XQuartz 2.5.3), but only for X11 windows.
     
  3. binbs thread starter macrumors newbie

    Joined:
    Apr 19, 2010
    #3
    I deleted X11 after installing XQuartz. Was this wrong? Where do I get X11 again if so.
     
  4. binbs thread starter macrumors newbie

    Joined:
    Apr 19, 2010
    #4
    ok I installed X11 again, and made sure that on both applications the "click through inactive windows" was checked. Still didnt help.

    Any help about the mouse acceleration?
     
  5. Jodles macrumors regular

    Joined:
    Dec 5, 2008
    #5
    I had the same gripe about the mouse acceleration. Googled it and a lot of people have been complaining about it for years. The biggest annoyance for me is that the acceleration curve seems more like a shelf than a curve...

    It's possible to get used to. But that takes time, so:

    For me, installing BetterTouchTool (awesome freeware app) pretty much resolved the issue for me. You can set the speed a lot higher than in OS X prefs, and it helped me a lot.

    + bettertouchtool has some awesome features for your trackpad and magic mouse as well.
     
  6. LPZ macrumors 65816

    Joined:
    Jul 11, 2006
    #6
    You misunderstood my post. Some applications (not so many, and mostly things ported to OS X from unix) use X11 to create windows on the screen. For such windows, setting preferences in X11 or XQuartz will have some effect. Native OS X apps don't use X11 for windowing, so such preference settings won't affect them.

    You can use X11 or XQuartz as your X11 app, but if you're looking for the ability to click on a link in an inactive Safari window and have that link followed then nothing related to X11 is relevant.
     

Share This Page