Clicking Internet Links in Email

Discussion in 'Mac Basics and Help' started by hexonxonx, Aug 18, 2008.

  1. hexonxonx macrumors 601

    Joined:
    Jul 4, 2007
    Location:
    Denver Colorado
    #1
    Something that happens on all my Macs:

    I get a message from the forum telling me there is a reply to a thread I am subscribed to. I click on the link to be taken to the thread and the only thing that happens is I am taken to an already open page in Safari and the link I clicked on didn't open. I click it again and I am taken to Safari where apparently it did open but now is opening once again in a new window.

    How do I get this to open only once and to open the first time I click a link in email?

    Thanks
     
  2. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #2
    Check your Safari preferences, specifically the General settings. Also, what version of Safari are you using? You can find out by opening Safari, going to the Safari menu, and choosing "About Safari".
     
  3. hexonxonx thread starter macrumors 601

    Joined:
    Jul 4, 2007
    Location:
    Denver Colorado
    #3
    Well I'm using 3.1.2. I set Safari to open links in new tabs and that is working. Thanks.

    I've had this happen for a year and never felt the need to ask anyone how can I stop this problem. Finally it just started really bothering me.
     
  4. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #4
    Are you sure you're giving the page enough time to load? Try clicking the link once. Then, when you go to Safari, give it time to load. If it doesn't, try refreshing the page, rather than clicking the link again. Does that help?
     
  5. hexonxonx thread starter macrumors 601

    Joined:
    Jul 4, 2007
    Location:
    Denver Colorado
    #5
    Yes I'm sure. I'm actually still having this problem. I thought I fixed it above but on my iMac, it is still taking two clicks on the link in the email to get the link to open.
     

Share This Page