Clicking noise form PSU when performing CPU intensive tasks

Discussion in 'Mac Pro' started by ray_uk, Aug 21, 2010.

  1. ray_uk macrumors member

    Joined:
    Feb 27, 2005
    #1
    Just over a month ago my 2008 Mac Pro started to make a clicking sound for a few seconds during the boot process and inside of either OS X or Windows when playing HD movies, HD Flash movies, when rendering in 3DS Max, and most loudest when playing 3D games. It will occasionally do it when scrolling through a rich content web page, but to a slightly lesser extent.

    I have been able to individually check each hard drive and cooler fan bar the one inside of the PSU as its not accessible but have checked to cooler close to the dvdrw and know its not that one either.

    I clean the system out twice a month with compressed air, and the sound is not there when viewing plain text still image web content or when viewing SD movies, or just playing back music in iTunes.

    Any suggestions would be greatly appreciated.
     
  2. 1mac macrumors newbie

    Joined:
    Dec 18, 2010
    #2
    seems like no one knows these issues.. i get the scroll noise as well
     
  3. ray_uk thread starter macrumors member

    Joined:
    Feb 27, 2005
    #3
    I rested the system on its side for about 3 or 4 days, thinking that if it something loose then maybe gravity tugging on it for a while might get it to go back into place, and it does actually appear to have done the trick.

    Might be worth a try it, seeing as how for me it beat spending $300 / £200 on a new psu to get rid of what was otherwise just a very annoying clicking sound.

    Good luck.
     
  4. ActionableMango macrumors 604

    ActionableMango

    Joined:
    Sep 21, 2010

Share This Page