Clicking noise from iphone when connected to hifi

Discussion in 'iPhone' started by Kissaragi, May 9, 2010.

  1. Kissaragi macrumors 68020

    Joined:
    Nov 16, 2006
    #1
    I used to play music a lot using my iphone connected to an NAD amp and Q acoustics speakers with a phono to 3.5mm adaptor cable. A few months ago i started getting a rhythmic, bass clicking noise, like a heart beat through the speakers as soon as i connected the iphone, its gets louder or quieter depending on the amp volume but changing the iphone volume does nothing. Music will still play but the clicking noise is there all the time in the background. I dont get this when I plug headphones into the iphone and if I plug a portable cd player into the amp using the same cable I also dont get this click.

    Its obviously the iphone doing this, but im not sure why or how to stop it?
     
  2. robbieduncan Moderator emeritus

    robbieduncan

    Joined:
    Jul 24, 2002
    Location:
    London
    #2
    Interference from the cell radios? Try turning on aircraft mode...
     
  3. iChristopher macrumors newbie

    iChristopher

    Joined:
    May 9, 2010
    Location:
    Cheshire, UK
    #3
    My 3G used to do this. Aircraft mode cured it.

    Curiously, my 3GS doesn't do it though.
     
  4. Kissaragi thread starter macrumors 68020

    Joined:
    Nov 16, 2006
    #4
    Just tried that and it makes no difference unfortunately.

    The sound is like a bu-dum, bu-dum, bu-dum with about a second between each bu-dum. its very regular and never seems to change pitch or tone. You can actually see the bass drivers on the speakers moving with each sound. Id think it was a faulty headphone jack on the iphone, but its fine with my shure headphones.

    *Edit* its an iphone 3gs
     
  5. Badfoot macrumors 6502

    Joined:
    Sep 27, 2009
    Location:
    London, UK
    #5
    Not close to an airport are you ?

    I had interference from a radar causing a similar sound, very rythmic, and cured it by wrapping the lead around a ferrite ring (like the thing you find on decent usb etc leads.
     
  6. Kissaragi thread starter macrumors 68020

    Joined:
    Nov 16, 2006
    #6
    Nope, miles from an airport here.

    Ive just tried the iphone on a friends hifi with a similar lead and it worked fine! Im really not sure what could be wrong, my iphone seems fine, my hifi seems fine, but the 2 together... :confused:

    *Update* It was my incipio case stopping the 3.5mm jack going all the the way in! The cable on my friends lead had a much smaller shoulder so it went in, but my QED lead is pretty big and obviously doesnt.

    Thanks for the suggestions guys, its good to be able to use it again.
     

Share This Page