clicking on links in safari and new window

Discussion in 'Mac Apps and Mac App Store' started by catcloud, Aug 29, 2015.

  1. catcloud macrumors newbie

    catcloud

    Joined:
    Aug 29, 2015
    #1
    Hello,

    I have this problem in Safari, that appeared unexpectedly: When I click on a link in a window, I don't want a new window to open, I want the link to open in the current window, at least as a default. If I want a separate window, I can always right click. This is how Safari worked until now, but suddenly it changed, and I can't find the place in Preferences where I can change it. I looked everywhere and performed numerous searches but can find nothing.
    Any ideas?

    Thanks!
     
  2. NonSoft macrumors member

    Joined:
    Jul 24, 2015
    #2
    In preferences under Tabs.

    The default should be 'Automatic', but you can change it to 'Always'.

    Screen Shot 2015-08-29 at 9.12.01 AM.png

    Personally, I always hold cmd when I want a new tab so I can't speak to how well the Automatic mode works.
     
  3. catcloud thread starter macrumors newbie

    catcloud

    Joined:
    Aug 29, 2015
    #3
    Thanks for your answer. But I don't want to open a new tab or a new window, that's the thing. I want the new link to open in the same window and in the same tab, replacing the old one. This is what was happening until now, anyway. I don't know how it changed. I updated the Java version, maybe it's related to that. This is strange though. I have been using browsers and Safari in particular for years, and the link always replaces the old one until I specified otherwise.
     
  4. NonSoft macrumors member

    Joined:
    Jul 24, 2015
    #4
    By default every link you click is now opening in a new tab/window?

    The only time I know of where a new tab/window is opened just by clicking a link (ie. non-user controlled) is if the link has target="_blank".
     
  5. catcloud thread starter macrumors newbie

    catcloud

    Joined:
    Aug 29, 2015
    #5
    Yes, that's right. Every single link I click on, e.g. after a google search, or within particular pages. I end up with a desktop full of safari windows!
     
  6. NonSoft macrumors member

    Joined:
    Jul 24, 2015
    #6
  7. catcloud thread starter macrumors newbie

    catcloud

    Joined:
    Aug 29, 2015
    #7
    Yes it does! The google settings seem to be ok, I checked them. I don't want to delete all my cookies because of the info stored there, but I guess I may have to.
     
  8. catcloud thread starter macrumors newbie

    catcloud

    Joined:
    Aug 29, 2015
    #8
    Ok, I deleted them and it solved the issue. Thanks a lot for your help!
     

Share This Page