cMBP 650M jitters, stuttering, skipping performance, in Boot Camp

Discussion in 'MacBook Pro' started by Diversion, Jul 31, 2012.

  1. Diversion macrumors 6502a

    Diversion

    Joined:
    Oct 5, 2007
    Location:
    Jacksonville, Florida
    #1
    I have two brand new cMBPs with the 1gb 650m (both) and i've noticed how horrible the stuttering, jittering, jerking the graphics in Boot Camp. If this was happening to just ONE of my cMBPs then i'd understand that maybe its just the one.. but both of my units are acting identically. Overclocking doesn't fix or improve anything, it happens on all games and all benchmarks i've ran. It looks horrible...

    Noticed how bad the 650m was behaving when I compared it to my Samsung notebook with 650m.. It's night and day smoother on the Samsung.

    I'm running the same exact drivers on the Macbooks as well as the Samsung and the Samsung is silky smooth compared to both Macs.. I'm not sure what's going on here. The Samsung does have 2gb of video ram compared to the 1gb in the Mac but when looking at MSI afterburner during gaming, it's not even coming close to using the full 1gb of video ram on the Mac so that can't be it.

    The funny part is that the Macs are getting higher benchmark scores against the Samsung, but it's so choppy so it looks a lot less playable and annoying over the Samsung.

    Anybody experienced this? I wonder if I should try different drivers again.
     
  2. mdapple macrumors regular

    Joined:
    Jun 29, 2012
  3. Diversion thread starter macrumors 6502a

    Diversion

    Joined:
    Oct 5, 2007
    Location:
    Jacksonville, Florida
    #3
    The latest from laptopvideo2go.. Unfortunately I don't think I remember if the jitters were there on stock (provided by Apple) drivers. I will be reloading the stock drivers tonight and seeing if they are any better.
     
  4. terraphantm macrumors 68040

    Joined:
    Jun 27, 2009
    Location:
    Pennsylvania
    #4
    I noticed the same thing on my rMBP in Windows - even on an external display. I think the drivers just aren't mature yet.
     
  5. mykelala01 macrumors 6502

    mykelala01

    Joined:
    May 17, 2009
    #6
    I just use the Bootcamp support driver and anything runs fine with my Hi Res cMBP
     
  6. MagnusB macrumors newbie

    Joined:
    Jul 24, 2012
    #7
    got the exact same problem with my retina macbook pro. Seems to happen when the temperature on the gpu reaches 97c. Have you checked yours?
     
  7. BlazednSleepy macrumors 6502a

    Joined:
    Apr 15, 2012
    #8
    I used whatever came with the bootcamp drivers and it was perfectly fine and smooth. Nvidia drivers should be out soon.
     

Share This Page