cmd.exe-no disk imac27" bootcamp

Discussion in 'Windows, Linux & Others on the Mac' started by mogens, Feb 13, 2010.

  1. mogens macrumors member

    Joined:
    Jan 24, 2010
    #1
    I just got my brand new Imac 27" i7 and it runs like a dream :)
    I'm trying to install windows 7 64bit on bootcamp. The install runs fine but just before it finishes I get a "cmd.exe-no disk" error ( something like: no disk in a:/can't be found).

    I created a usb stick according to the directions on apple: iMac Late 2009 Windows 7 Drivers

    http://www.apple.com/downloads/macosx/apple/firmware_hardware/imaclate2009windows7drivers.html

    But that don't make a difference :-(
    When i click continue or retry my Imac restarts, and I get a "press any key to boot from cd or dvd..." but the computer doesn't react to any key stroke.

    I'm new to bootcamp.-so any suggestion will be welcome.
     
  2. asm84 macrumors newbie

    Joined:
    Mar 7, 2010
    #2
    I am having the same problem.
    when booting up in windows 7 (not on the windows 7 boot dvd) screen just goes black and stays that way with no reaction if i type on the keyboard.. tried the "deleting of drivers fix" but this doesn't work either. any help would be great...
     
  3. Zortrium macrumors 6502

    Joined:
    Jun 23, 2003
    #3
    The black screen problem is the result of not having compatible graphics drivers on the Windows side. I fixed it by rebooting into Mac OS X and starting up my BC partition in VMware, then deleting the ATI driver through that. I then rebooted into Windows and it used the default VGA driver, which let me install an up-to-date ATI driver.
     
  4. asm84 macrumors newbie

    Joined:
    Mar 7, 2010
    #4
    thanks I'll try a version of this when i get off work. I've read allot about the "black screen video card issue" but I've haven't seen anyone reporting a cmd.exe-no disk error when this occurs so still not 100 % sure this is a standard video card error :) (but if really hoping it's that simple).
     
  5. hamstersar macrumors newbie

    Joined:
    Mar 15, 2010
    #5
    I'm having precisely the same problem as Mogens. So far I've been bashing my head against it for about three days straight and I still haven't managed to get anywhere with it. Help?
     
  6. asm84 macrumors newbie

    Joined:
    Mar 7, 2010
    #6
    i finaly fixed this by making the boot-camp partition writable in mac osx then deleting the offending driver files. When i did this windows boots up and you can update windows 7 to get the problem free drivers (the first time you boot windows after doing this windows may take a couple of minutes to boot with the screen just staying black)

    you make the ntfs windows partition writable in mac osx by downloading and installing macfuse ( http://code.google.com/p/macfuse/ ) and ntfs-3g (http://macntfs-3g.blogspot.com/)
     
  7. asm84 macrumors newbie

    Joined:
    Mar 7, 2010
    #7
    by the way big thanks to Zortrium for getting me to see a different kind of solution to this problem.
     
  8. Novastate macrumors newbie

    Joined:
    Aug 17, 2011
    #8
    I have the same problem!

    How do i know witch file to erase in windows when i boot my patition with parallels?

    Thanks!
     

Share This Page