Cmd+L has become "Quit" and other weird shuffled cmd keys

Discussion in 'Mac Basics and Help' started by SimplyMints, May 7, 2009.

  1. SimplyMints macrumors newbie

    SimplyMints

    Joined:
    May 6, 2009
    Location:
    Eastern Oregon
    #1
    I've done a fair amount of searching, and didn't find this anywhere, so I hope I'm not repeating a thread.

    My command keys for applications seem to have been shuffled. For example, when I press cmd+L, the application quits. If the application has a command assigned to cmd+L, it is activated when I press cmd+Q. Another example is in browser windows, if I press cmd+T, I bookmark the page, whereas if I press cmd+D, I create a new tab. All my cmd keys across all applications are just messed up. I suppose I could learn where they all went and just use them like this, but is there a way I can put them back the way they are stated in the menus? I don't even know how this happened. They just suddenly started being like this. Funky.
     
  2. BlueRevolution macrumors 603

    BlueRevolution

    Joined:
    Jul 26, 2004
    Location:
    Montreal, QC
    #2
    Check your keyboard layout.  -> System Preferences -> International -> Input Menu. Normally only the US option would be checked in the list.
     
  3. SimplyMints thread starter macrumors newbie

    SimplyMints

    Joined:
    May 6, 2009
    Location:
    Eastern Oregon
    #3
    Woohooo! Weird, thanks, fixed it :)
     
  4. BlueRevolution macrumors 603

    BlueRevolution

    Joined:
    Jul 26, 2004
    Location:
    Montreal, QC
    #4
    Out of curiosity, what layout was it using? DQ is the only one I know of that is different with the command key, and it uses the QWERTY layout in that case, so you'd have noticed not being able to type anything except keyboard combinations.
     
  5. SimplyMints thread starter macrumors newbie

    SimplyMints

    Joined:
    May 6, 2009
    Location:
    Eastern Oregon
    #5
    I had downloaded a pack of windows-keyboard friendly keyboard maps for my German keyboard (since Apple absolutely refuses to sell me a German keyboard unless I actually physically travel to Europe myself), and I had the German - Microsoft layout selected. I didn't even think of that! My brain hasn't been working right lately, lol!

    But anyway, you set me onto the right track! I went into the keyboard layout and looked at the cmd key outputs, and they were all messed up. I still don't know how that happened since with the exception of Z and Y being switched around, all the English letters are in the exact same place on both English and German keyboards, and the Z and Y cmd outputs were actually correct! However, I set them all straight and toggled my keyboard layout in the international preferences, and it all started working perfectly! And I didn't even have to log out once! You can bet that if this were Windows, I would have had to restart the computer at least 3 times to fix this :p
     
  6. BlueRevolution macrumors 603

    BlueRevolution

    Joined:
    Jul 26, 2004
    Location:
    Montreal, QC
    #6
    No joke. Changing keyboard layouts on Windows is a pain in the ass.
     

Share This Page