C'mon apple, fix non-US account App Store "Categories"

Discussion in 'iPhone' started by arrow201, Sep 13, 2009.

  1. arrow201 macrumors member

    Joined:
    Sep 30, 2008
    #1
    Noticed for the past few days on the iPhone _itself_ (not iTunes) when i
    press the "App Store" icon, Categories does not work as it should.

    Tapping "Categories" - all i see, for all the rows, is the "Skype" icon and
    beside it says "App Store", if i press this, then it looks like same as tapping
    the "Featured" button
    The bottom buttons, "Featured","Top 25", "Search", "Updates", all work
    normally as supposed too.
    i saw this with iTunes 8 and firmware 3.0 ....upgrading both didn't change
    anything.
    This shows up on my (normal) Canadian account _only_ (i don't know
    about other countries) , if i sign in under my US account, the "Categories"
    button works as it should

    Yesterday, i went into an apple store and asked a "genius" if he heard of this,
    he said, "no" with a surprised look ...he then grabbed another iPhone and tried
    it ...same problem ...he said, "yep, that's an apple problem, thanks for letting
    me know" ......
     
  2. VPrime macrumors 68000

    VPrime

    Joined:
    Dec 19, 2008
    Location:
    London Ontario
  3. GamaFu macrumors regular

    Joined:
    Apr 12, 2007
    #3
    I too have this problem on my iPhone. However, if you go to Settings -> Store, and sign out there and sign in again. App Store should work as it should. At least it fixes the mess up Categories for me.
     
  4. arrow201 thread starter macrumors member

    Joined:
    Sep 30, 2008
    #4
    Thanks ! ...i tried this a number of times over the weekend but didn't
    work and gave up trying this method ...now it works :)
     

Share This Page