cMP 10.10.3 w/ATI 7970 or simliar UI Lag

Discussion in 'Mac Pro' started by thefredelement, Apr 10, 2015.

  1. thefredelement macrumors 65816

    thefredelement

    Joined:
    Apr 10, 2012
    Location:
    New York
    #1
    I know this problem has been reported in various threads since 10.10 but for me it seems to have gotten much worse with the official 10.10.3 release, specifically with Safari, the entire UI will lock up for around 5 - 10 seconds after something needs to be refreshed in Safari.

    The input lag in text boxes still exists but it's not as drastic as it once was.

    Does anyone have any tips on fixing this?
     
  2. crjackson2134 macrumors 68020

    crjackson2134

    Joined:
    Mar 6, 2013
    Location:
    Charlotte, NC
    #2
    Apple doesn't even have a fix. I get the same text input lag on 3 different cards, including my HD 5870 & HD 7970. The HD 7970 is a faster card and it shows with running apps. that need the extra horsepower. The lags you are bothered by seem to be caused by the UI itself, or the supplied drivers.

    It's been there since Yosemite DP1 for me and it hasn't improved with any point release. Mavericks (any version) did not have ANY such problems. The way things are going, I don't expect Apple is going to fix it at all. It seems they simply don't give a rats..s.

    I'm not so bothered by it that I can't use it, but I've been thinking hard about reinstalling Mavericks on one of my scratch drives. I wish I had a decent/compatible nVidia card to compare with. I do have an 8800GT in a PC that I don't use. I wonder if it would work in my MP.
     
  3. thefredelement thread starter macrumors 65816

    thefredelement

    Joined:
    Apr 10, 2012
    Location:
    New York
    #3
    I have a Mavericks install on a sata2 64GB SSD and it doesn't have any lag at all, it feels much faster because of it.

    I'm not sure what to do either, I bought the card from MVC about 15 months ago so I'm not really ready to throw away the investment and get an Nvidia. Though I don't really care about what brand is in there, I just want it to not lag.

    It will probably drive me to get an Nvidia to be honest, now that I write it all out, I"ll probably order one in frustration the next time it happens.

     
  4. crjackson2134 macrumors 68020

    crjackson2134

    Joined:
    Mar 6, 2013
    Location:
    Charlotte, NC
    #4
    Well, I bought mine only a month(+) or so ago. Specifically because of the UI lag. Imagine my disappointment.

    However, photoshop and FCPX are of a magnitude faster, and I have no problems with this card at all. I went with AMD because of FCPX and because there are never any issues with OS updates (since it's the same basic card as the D700). I figured it would have longer support life since it's nMP like.

    I would have loved to get one of the new Maxwell nVidia cards, but I don't want the driver hassle every time an update comes out. Plus I like the fact that I can pretty much run any version of OS X out of the box with this card.

    My MP came with 10.8, and if I decided to reinstall that for any reason, it would be trouble free. With a Maxwell based card you have to start off with Yosemite as the lowest version of OS X. Since I'm starting to lean towards going back to an earlier OS X, the current card was my best bet anyway.
     
  5. thefredelement thread starter macrumors 65816

    thefredelement

    Joined:
    Apr 10, 2012
    Location:
    New York
    #5
    I am in the exact same boat as you, do you think if we had one of each we'd be OK?

     
  6. crjackson2134 macrumors 68020

    crjackson2134

    Joined:
    Mar 6, 2013
    Location:
    Charlotte, NC
    #6
    I think I may stop upgrading my OS until +1 version is always at end of life. I know a lot of people seem to love 10.10. I am not one of them so far.
     
  7. Jardins de Vin macrumors 6502a

    Jardins de Vin

    Joined:
    Nov 6, 2012
    Location:
    Europe
    #7
    I would think this is more of an OS problem than driver/card compatibility problem, no? Or does this not affect people on MacBooks, etc.?

    I have a 7950 Mac Edition and sometimes get the text boxes lag when writing something like here right now. (just had the freeze, twice now)
     

Share This Page