CNN airply stops when iPhone 4 goes to sleep

Discussion in 'Apple TV and Home Theater' started by jmcrutch, Oct 18, 2011.

  1. jmcrutch, Oct 18, 2011
    Last edited: Oct 18, 2011

    jmcrutch macrumors regular

    Joined:
    Jul 27, 2010
    #1
    This is a new issue for me, not sure if its related to iOS5 or not.

    I enable airplay via the CNN app to watch the channel on my AppleTV2. Everything is working fine then after a couple of minutes my iphone goes to sleep (Auto-Lock) and airplay is lost.

    It used to just stay on, avoiding sleep, or either the airplay continued even after Auto-Lock, I don't remember.

    I shouldn't have to go turn off the sleep (Auto-lock) function, so don't suggest that. I would then have to re-enable it --- not how it's supposed to work.

    ----------

    Note that if I monitor the iphone screen when it dims, I can touch it to bring it back to full brightness and avoid having it go to sleep (Auto-Lock).

    Again, this is a workaround, but not how its supposed to work (nor how it used to).
     
  2. nwcs macrumors 65816

    nwcs

    Joined:
    Sep 21, 2009
    Location:
    Tennessee
    #2
    This is how it always has worked for me. I'd love if you could do it while locked if already playing but I don't see them doing that yet.
     
  3. captndave macrumors newbie

    Joined:
    Aug 10, 2011
    #3
    same problem with PBS

    yeah I have the same problem. AirPlay Did used to run in the background and iOS 5.1 did not fix it. anyone found out anything else yet??
     
  4. HazyCloud macrumors 68030

    HazyCloud

    Joined:
    Jun 30, 2010
    #4
    We aren't up to 5.1 yet. We're at 5.0.1.

    Topic: I actually had the same issue with a Vimeo video recently. The second my 4S went to sleep, the Apple TV stopped playing it. I thought it was pretty ridiculous.
     
  5. testerdennis macrumors member

    Joined:
    Aug 7, 2011
    #5
    On your iphone or ipad Settings,General,Auto-Lock, Never.. Only way I know how to make it work.
     
  6. HazyCloud macrumors 68030

    HazyCloud

    Joined:
    Jun 30, 2010
    #6
    That's not a bad workaround. I'll keep that in mind next time I'm AirPlaying.
     
  7. captndave macrumors newbie

    Joined:
    Aug 10, 2011
    #7
    yeah ive been using that work around but it precludes any multi tasking and I'm sure it used to run in the background??? right??? also it drains the batt. ok if ur plugged in but does anyone know if it I'd bad for the iPad screen to leave it on for 2 hours without changing the " picture" ie wo screensaver?
     
  8. ipedro macrumors 68040

    ipedro

    Joined:
    Nov 30, 2004
    Location:
    Toronto, ON
    #8
    Report bug to Apple

    It's definitely a bug. Prior to iOS5, AirPlay would not be interrupted. I know because I used to leave Al Jazeera playing on my TV for hours with the iPhone in the bedroom in its dock.

    If more people report this bug to Apple, they'll make it a priority:

    http://www.apple.com/feedback/iphone.html
     

Share This Page