Coconut Battery not Displaying Correct Charge Cycles

puma1552

Suspended
Original poster
Nov 20, 2008
5,559
1,917
Replaced my OEM battery with an OWC/NuPower battery in my 2010 MBP and did a clean install of High Sierra (to my understanding, OWC/NuPower is the best/most reliable/closest to OEM battery you can get).

Installed Coconut Battery, initially said the new battery had 1 cycle. Now, the battery should have 4-5 cycles on it, but Coconut still says 1 and won't change from that. I uninstalled/reinstalled, and it still says 1 cycle. Everything else in the app looks correct including battery manufacture date, design mAH, and battery health of 100%. It's just the cycles that aren't appearing correctly.

Anyone else have this issue? Is this a problem unique to third party batteries and Coconut Battery?
 

MacGizmo

macrumors 65816
Apr 27, 2003
1,403
768
Arizona
I've not had that issue, but when I was running Coconut Battery I noticed that the charge amount shown in the menubar was dramatically different than Apple's built-in battery menubar utility... and Apple's was more accurate base on actual use (Coconut said I had 5% battery charge, while Apple's said I had over 20% - and I was able to keep working for quite a while without charging, leading me to believe the 20% the OS was reporting and not Coconut's).

I stopped using Coconut Battery for that reason.
 

puma1552

Suspended
Original poster
Nov 20, 2008
5,559
1,917
Hmm, so after a couple weeks now, Coconut Battery eventually changed to 2 cycles, but only after the one time I let the battery die while I was using the machine. At this point it should probably have between 5-10 complete cycles, based on summing up lots of smaller, partial discharges before re-plugging it in.

Not sure what's going on. Reinstall didn't help. Not going to worry about it I guess.
 

FeliApple

macrumors 65816
Apr 8, 2015
1,268
458
This is probably a stupid question, but I ask because I don't know: the internal cycle report doesn't work with non-OEM batteries? I mean the one in system report.
 

puma1552

Suspended
Original poster
Nov 20, 2008
5,559
1,917
This is probably a stupid question, but I ask because I don't know: the internal cycle report doesn't work with non-OEM batteries? I mean the one in system report.
Never knew that was in there...but yes, that one also shows 2 cycles, wtf?
 

Audit13

macrumors 601
Apr 19, 2017
4,376
1,098
Toronto, Ontario, Canada
I have a third-party battery from Amazon in my early 2015 Air. Coconut Battery and Mojave's system report show the same cycle count of 12 which is what is should be.
 

puma1552

Suspended
Original poster
Nov 20, 2008
5,559
1,917
I have a third-party battery from Amazon in my early 2015 Air. Coconut Battery and Mojave's system report show the same cycle count of 12 which is what is should be.
For whatever reason, both the High Sierra system report and Coconut are reporting the same number, which is good, but it clearly isn't summing up partial charges (say 5 partial 20% discharges) and counting it as a cycle. Still at 2.
 

Audit13

macrumors 601
Apr 19, 2017
4,376
1,098
Toronto, Ontario, Canada
For whatever reason, both the High Sierra system report and Coconut are reporting the same number, which is good, but it clearly isn't summing up partial charges (say 5 partial 20% discharges) and counting it as a cycle. Still at 2.
Strange. I suppose it's not an issue at the moment if everything is working.