CoD4 Graphics Stumbling 9400M

Discussion in 'Mac and PC Games' started by Killery96, May 12, 2011.

  1. Killery96 macrumors 6502

    Joined:
    Mar 20, 2011
    #1
    Hi,
    I play CoD4 on a 2009 13" Macbook Pro. My specs are a Geforce GT 9400m (256), a 2.26 C2D, 4 Gigs of 1333mhz RAM.
    I play CoD4 at 1152x 720 or something like that. Textures are all high, and the rest of the stuff is off, like shadows. I usually get around 30ish FPS on Multiplayer.
    My issue is that, after about three-and-a-half minutes of gameplay in ANY game with ANY connection speed, even if it's been smooth before, I get lag/hiccups that will have short periods of slowdown, then fast, then short periods of slowdown (1.5s), then fast again. This ends after around two minutes. Is this performance issue due to the GPU? Anyone else get this?
     
  2. mac2x macrumors 65816

    Joined:
    Sep 19, 2009
    #2
    It might be heat. Any idea what your temps are?

    TBH, I've pretty much stopped playing CoD4 on my MBP since building a gaming PC. OTOH, you are lucky to get 30 frames from that 9400m. :eek:
     
  3. Killery96 thread starter macrumors 6502

    Joined:
    Mar 20, 2011
    #3
    I really don't know. I don't have any temp monitoring software, however the computer is silent and no fans ever spin up until I've been doin it for at least half-an-hour.
     
  4. StopSign24 macrumors regular

    Joined:
    Feb 1, 2010
    #4
    It's a temperature issue, I had the same thing happen. Download SMCfancontrol and turn up the fans when you play.
     
  5. Killery96 thread starter macrumors 6502

    Joined:
    Mar 20, 2011
    #5
    what sort of RPM are you suggesting?
     
  6. Ace134blue macrumors 6502a

    Ace134blue

    Joined:
    Sep 17, 2009
    #6
    If your MBP isnt hot dont bother with that crap.
     
  7. Killery96 thread starter macrumors 6502

    Joined:
    Mar 20, 2011
    #7
    Normally I would agree and I don't usually like the idea of tweaking hardware or even simple things like fan revving, but it seems to have worked, whatever it is... ...Only lag I experience now is because of my terrible internet connection.
     
  8. Ace134blue macrumors 6502a

    Ace134blue

    Joined:
    Sep 17, 2009
    #8
    Than the heatsink is not making good contact with the CPU if the metal above the keyboard wasnt hot.
     
  9. mac2x macrumors 65816

    Joined:
    Sep 19, 2009
    #9
    Did the OP say that the keyboard was hot or not?
     

Share This Page