COD4 Players - What are you running at? I'm going crazy!

Discussion in 'Windows, Linux & Others on the Mac' started by machspeed5, Oct 26, 2009.

  1. machspeed5 macrumors member

    Feb 11, 2008
    I can swear I used to play this game at much higher rez/quality. I remember playing at 1280x720 with all settings maxed out (no AA) and averaging somewhere between 20-30 fps in multiplayer. It was very playable.

    I have an early 2008 MBP 2.5GHz/4GB RAM/8600M GT 512MB and I've been scratching my head for the last few days because I am getting awful FPS out of COD4 under boot camp and I can't figure it out!

    I'm playing at 640x480 with all settings OFF (no AA) or LOW and I'm getting about 15 fps average single or multiplayer. Its driving me nuts.

    I was so annoyed/disgusted I formatted my boot camp partition and reinstalled a fresh copy of Win XP SP3...only to get identical sub-par I've formatted again, and did a fresh install of Windows 7 Ultimate 64 bit and this performance out of my 8600 continues to irritate/baffle me. No difference!

    Is there anyone else out there that plays this on an 8600M GT? What settings do you use and how does it run?

    I'm utterly confused and baffled.
  2. machspeed5 thread starter macrumors member

    Feb 11, 2008
    any ideas? was there a like a firmware update for the 8600M GT ever? maybe to make it run less hot due to the manufacturing defect? i just can't explain this awful performance. :(
  3. lumberjack macrumors member

    Oct 23, 2009
  4. machspeed5 thread starter macrumors member

    Feb 11, 2008
    yea i tried both the boot camp 3.0 drivers from (snow leopard) and the latest nvidia drivers (currently 186.81) from their site. the latest nvidia improved performance noticeably (estimate 5fps) but its still far far from how it used to run.
  5. ZManChu macrumors newbie

    Jun 30, 2007
    hello! I have the exact same laptop and cod runs perfectly under boot camp. I am running windows xp sp3 using all the default boot camp drivers. I have the res set to 1280x800 with EVERYTHING set to off and it flies. Make sure the anti-aliasing is set to off. Thats the #1 item that slows everything down.
  6. ildondeigiocchi macrumors 6502a


    Dec 30, 2007
    Go in the NVIDIA Control panel and make sure AA is set to application controlled.

Share This Page