Codesign failed exit code 1 (resolved)

Discussion in 'iOS Programming' started by TripleJ, Nov 20, 2008.

  1. TripleJ macrumors regular

    Jul 30, 2008
    I'm trying to send my app off for distribution (which I've done successfully with other apps several times before), and every time I try to build the program for distribution I get a ' object file format invalid or unsuitable. codesign failed with exit code 1' error.
    I've tried clean all targets and recreating the distribution profile but i still get the same error.

    Would anyone happen to know the solution to this? It'd be much appreciated!

    Thank you in advance!

    Edit: I manged to sort it out :) Thanks for looking!
  2. plusbryan macrumors newbie

    Aug 29, 2008
    Care to enlighten those who are having the same problem?
  3. TripleJ thread starter macrumors regular

    Jul 30, 2008
    I'd managed to mess up the Executable line in the info.plist file. Just in case yours is the same, make sure it says ${EXECUTABLE_NAME}
    Hope that helps :)

Share This Page