Color Stylewriter 2500 problem

Discussion in 'Apple Collectors' started by macintoshmartin, May 29, 2010.

  1. macintoshmartin macrumors newbie

    macintoshmartin

    Joined:
    May 29, 2010
    Location:
    Antarctica
    #1
    Hi. I need some help with a malfunctioning color stylewriter 2500. Whenever I try to make a test page, it just passes through the printer without printing anything. I've already replaced the ink cartridges. Any ideas?
     
  2. MacTech68, May 30, 2010
    Last edited: Jan 30, 2011

    MacTech68 macrumors 68000

    MacTech68

    Joined:
    Mar 16, 2008
    Location:
    Australia, Perth
    #2
    Has this problem just occurred or did you dis-assemble the beast and this problem began after re-assembly?

    There are cams that need to be aligned together on the rear paper feed tray for things to happen correctly.

    You might also want to pay attention to the paper feed sensor which might be telling the machine that paper is "permanently" loaded. The logic here is that the printer is trying to eject the paper it "sees" when turned on before loading a new sheet to perform a self test, but because the paper feed sensor is jammed it's as if the paper never leaves the printer.

    Does that make sense?

    EDIT: I should ask, does it sound like it's printing? IE, does the printe head carriage move left to right or does it just feed the paper only?
    ________
    Jaguar XJ13 picture
     
  3. macintoshmartin thread starter macrumors newbie

    macintoshmartin

    Joined:
    May 29, 2010
    Location:
    Antarctica
    #3
    I haven't taken the printer apart, and the print head moves from the middle to the right, then the paper feeds out, and then the print head moves toward the middle and the amber light starts blinking at the top of the case.
     
  4. BarnacleGrim macrumors newbie

    Joined:
    Apr 18, 2010
    #4
    That blinking amber light (steady power light, yes?) means there is a cartridge error.

    You said you replaced the ink cartridges, by that I guess you mean the ink tanks? Do you have a spare cartridge (tank holder and print head assembly) to test? I have the same problem with my 2500, and I have a vague idea that I once had two cartridges, but where the second one went is beyond me.
     
  5. MacTech68, Jun 2, 2010
    Last edited: Aug 25, 2011

    MacTech68 macrumors 68000

    MacTech68

    Joined:
    Mar 16, 2008
    Location:
    Australia, Perth
    #5
    Yes. This is what I recall. The only other possibility is ink on the gold contacts on the side of the print head or the gold contacts they make contact with in the carriage holder.
     
  6. macintoshmartin thread starter macrumors newbie

    macintoshmartin

    Joined:
    May 29, 2010
    Location:
    Antarctica
    #6
    I don't think it's the gold contacts, I have cleaned both of them them with some alcohol, so maybe I just need to replace the print head.
     

Share This Page