Comcast disconnects with Mac, not Windows

Discussion in 'Mac Basics and Help' started by bhound89, Jun 11, 2009.

  1. bhound89 macrumors newbie

    Joined:
    Jun 29, 2008
    #1
    We have Comcast internet hooked up to a Linksys router. When only Windows machines are using the connection, everything works fine. When I use my Macbook Pro on the connection, it works for a while, then eventually the connection dies for everyone, and usually restarting the modem makes it work again. I am now trying to use the connection on Windows XP on my Macbook Pro using Boot Camp, and it seems to be working, so it seems like the modem doesn't like something about Mac OS X.

    Any ideas?
     
  2. tempusfugit macrumors 65816

    Joined:
    May 21, 2009
    Location:
    Chicago
    #2
    is the macbook pro the only wireless device in use?


    I have comcast/linksys in minneapolis and it works fine.

    however, I did run into issues when I lived in the chicago area, the way newer macs do dns lookups caused latency because it was trying to retrieve ipv6 records that comcast didn't employ or something like that.

    To fix that (I noticed all my windows computers used the web fast, but the pages on my mac took forever to start loading) I manually changed the dns servers from default to free in my router settings.

    For example, try changing them to opendns.com's dns servers which are the following:
    208.67.222.222
    208.67.220.220


    These will provide the macs with relevant ipv6 information they are requesting.


    Not saying thats definitely your problem, but it did help me once upon a time when i was having mac issues on a linksys network on comcast, so I thought I'd mention it. Turns out it wasnt the router or the computer, but comcast itself.

    I use a brand new top of the line cisco router (dual band N, gigabit etc) and that one never has to get reset but other linksys routers I've had in the past have required many unplug/replug in's. The old ones all seem to be prone to this.

    good luck.
     

Share This Page