Command and conquer 3 won't start

Discussion in 'Mac and PC Games' started by ed1.crouch, Jan 30, 2016.

  1. ed1.crouch macrumors newbie

    ed1.crouch

    Joined:
    Jan 30, 2016
    #1
    So i managed to find a mac-version of CC3, i installed it but it keeps freezing on the loading screen (see screen shot)

    Any ideas?

    Please keep answers "easy to understand" as i'm not a techy guy

    Thanks!

    Ed
     
  2. Dirtyharry50 macrumors 68000

    Dirtyharry50

    Joined:
    May 17, 2012
    #2
    On newer versions of OS X I think you need to just abandon ship there given your not being the tech oriented type. There is a way to get the Windows version working with something called Wineskin but that requires learning how to do that to some degree even when someone else has fashioned what is often referred to as a "wrapper."

    For Command and Conquer games, the best way to go is installing Windows on a Mac using the Bootcamp utility, if you are willing to do that. Of course, then you wind up having to buy Windows too and learn a thing or two about using that so I am guessing you probably would not be interested in that either.

    One thing you can do to have some C&C fun for free with some older titles in the series is to visit http://cncnet.org where die-hard fans have fixed up the originals to run on modern systems and since Electronic Arts gave these titles away for free in the past, it's possible to play the original Tiberian Dawn, Red Alert and I think Tiberian Sun (the second C&C title in the series) for free. All you do is download them and and drag them into your Applications folder and away you go! They have helpful forums too. They have even cooked up multiplayer support so if you enjoy online play you can. All this is legitimate and free and having tried them I can tell you they work just fine on the latest OS X El Capitan. So all is not lost. The classic games are still a lot of fun, at least I think so although they won't have graphics as good as the newer ones of course.

    Lastly, on the Mac App Store you can get a recent Aspyr port of Command and Conquer:Generals with its expansion but you should know that since El Capitan released there is some problem with Apple's Game Center and this game which uses it for multiplayer support. So until that gets fixed (hopefully) you need to stick with the single player campaigns and skirmishes but that's plenty of fun. The fix to run this is you must log out of Game Center which is easy enough to do and also unplug your internet temporarily when playing this game. After you can plug back in and log back in for anything else that relies on Game Center.

    So that's all the C&C news that's fit to print and I hope you find that helpful and have some fun commanding and conquering!
     
  3. fotmasta macrumors newbie

    fotmasta

    Joined:
    Jan 3, 2017
    Location:
    Berkeley
    #3
    I am in the same boat. I was playing a pirated version to see if it worked and it did. So then I did the right thing and bought the game. And guess what- the legal copy doesn't work. Try to do a good thing and get it right in the neck.
    I would have just kept playing the pirate version, but the multiplayer doesn't work.

    The difference appears to be legal version = 1.0.6, pirate version was 1.0.8

    Naturally I tried to patch up to 1.0.8. The patcher throws an error in the console. Missing libcrypto.0.9.dylib. Well I tried to sym-link the version I had, but SIPS security won't let me (10.11.6)
    I used a second machine (10.6.8) to patch to 1.0.8. The dylib was incompatible. I copied the one over from El Cap and renamed it. The patch ran and completed but with a crap-ton of errors. There appear to be a gazzillion SHA checksums of files and a lot of them failed.

    The 1.0.9 patcher doesn't work at all.

    I opened a case with EA. If I can get this to work I will be so happy. What a really, really, great game. I want to play multiplayer though. Tired of playing with myself.
     

Share This Page