Mac "Command not found" with RVM, etc

iamneek

macrumors newbie
Original poster
Mar 3, 2012
7
0
Hi all, this is my first post but I am hoping you all can help me here. I know my way around computers, but apparently not as much as I thought.

I finally upgraded to 10.7.3 last night, and also downloaded XCode as well.

I wanted to pursue Ruby/RoR so I went to the Aptana site and downloaded the Aptana studio from the website. I downloaded git and installed it, and I figured I was good to go. So with RVM install it lays it out pretty straightforward, or so I thought.

I tried $ bash -s stable < <(curl -s https://raw.github.com/wayneeseguin/rvm/master/binscripts/rvm-installer) but it then says "-bash: $: command not found"

So I did a sudo command, and that installed it (I think, I can't find it anywhere). But it won't work for ANY OTHER command. Everything comes up as "command not found".

It shows that git is located in usr/local, so does anybody have any idea as to what the problem may be, and what I can do? I really want to get started on learning Ruby and not spending my whole Saturday figuring out some error that I couldn't even begin to figure out on my own.

Many thanks!!
 

larkost

macrumors 6502a
Oct 13, 2007
536
1
My first guess is that you are thinking that the dollar sign is part of the command. It isn't, it is just the command propt that is already there when you start typing.

The second part is that if things are installed into places that are not on your $PATH (use `echo $PATH` to get this), then by default the command line will not search there for them when trying to interpret what you wrote. This is all part of the basic (but initally cryptic) useage of the command line, and if you are serious about working with the lower layers of MacOS X, then you should find a book and get familiar with it.
 

iamneek

macrumors newbie
Original poster
Mar 3, 2012
7
0
My first guess is that you are thinking that the dollar sign is part of the command. It isn't, it is just the command propt that is already there when you start typing.

The second part is that if things are installed into places that are not on your $PATH (use `echo $PATH` to get this), then by default the command line will not search there for them when trying to interpret what you wrote. This is all part of the basic (but initally cryptic) useage of the command line, and if you are serious about working with the lower layers of MacOS X, then you should find a book and get familiar with it.
Thanks for your reply. Someone mentioned to me that $ isn't part of the command when I asked for help somewhere else, so I got that part figured out. (Thanks though for mentioning it, I never saw it mentioned anywhere else)

When I type in
Code:
echo $PATH
I get
Code:
/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/X11/bin:/usr/local/git/bin:/Users/XXXX/.rvm/bin

*XXXX = My username

I'm not really looking to get familiar with the lower levels of OS X, as it's not quite what I'm looking to accomplish at this time, I'm just trying to get this to work so I can get to coding Ruby with Aptana.

----------

How about a screenshot of the terminal session?
I closed out the terminal since I posted it since then.

However, when I tried downloading and installing RVM, that worked, however now when I type in:

Code:
source ~/.bash_profile
according to the installation process on RVM, it comes up as
Code:
-bash: /Users/*****/.bash_profile: No such file or directory
So, this is all really confusing me.
 

iamneek

macrumors newbie
Original poster
Mar 3, 2012
7
0
I ended up doing the install of Ruby 1.9.3, but I still get [the same error]
 
Last edited by a moderator:

robvas

macrumors 68030
Mar 29, 2009
2,801
372
USA
\
However, when I tried downloading and installing RVM, that worked, however now when I type in:

Code:
source ~/.bash_profile
according to the installation process on RVM, it comes up as
Code:
-bash: /Users/*****/.bash_profile: No such file or directory
So, this is all really confusing me.
There's no .bash_profile by default. You can create one, however.