Command-Tab, Dashboard key not working

Cuprous

macrumors member
Original poster
Oct 10, 2007
58
2
For a while now the command-tab, dashboard key and spaces key do not work. I press the key and nothing happens. If I restart the OS (OS X 10.5.5) they work but only for a short time and stop working again. Other accounts on the system work fine and do not have this problem. Any ideas?
 

DJMad

macrumors newbie
Mar 17, 2004
27
0
Seattle
I have been having the same problems with a new imac. Command tab seems to stop working ~1-2hrs into operation. Im sorry I don't have a fix for the problem yet, but at least it seems semi common.
 

carlosbutler

macrumors 6502a
Feb 24, 2008
687
0
London City
i have not experienced this problem, although i have had worse problems (not to do with Mac OS X but dual boot). but have you checked after it stops working to see that everything is still selected in the system preferences, just incase they somehow untick them selves?

if not then try another keyboard or something. you said that other accounts were fine, so the keyboard thing is ruled out. but create a new fake account, see if it does the same thing. if not then you may have a file missing.
 

sysbot

macrumors newbie
Nov 25, 2008
1
1
Fix

I have found that go to the Terminal and issue.

killall Dock

Will restart the Dock app and resolve the issue. Appeared to be the Dock problem.
 
  • Like
Reactions: sorri

unclebernie

macrumors newbie
Jul 10, 2010
1
0
command-tab failed in 10.6.4 too; killing dock fixed.

Command-tab failed my new lap-top with OS 10.6.4. Thanks to the above posts I fixed it by killing the dock! Who would have thought. "killall" apparently produced no results but "ps -ef | grep -i dock" identified the dock process that I then killed, and all went back to normal. Thanks !
 

drdunga

macrumors newbie
Nov 4, 2009
4
1
I had the same trouble (command-tab not working) and all I needed to do was to activate my dock with Fn-F12 and let it load. I didn't have to 'kill' anything.

David
MBP 10.5.8
 

beaudouin

macrumors newbie
Sep 14, 2010
1
0
command tabs failed

Command-tab failed my new lap-top with OS 10.6.4. Thanks to the above posts I fixed it by killing the dock! Who would have thought. "killall" apparently produced no results but "ps -ef | grep -i dock" identified the dock process that I then killed, and all went back to normal. Thanks !
Hi could u shared detailed action step by step, as I am new to Mac. Thanks

Had been able to use the command tab to enlarge/reduce screen size, but it fails to copy/paste function
 

iaian7

macrumors newbie
Jul 4, 2010
3
0
Rochester Hills, MI
Similar issues in 10.6.4!!

Several times a month, after running for a few hours (4+ hours is the usual timeframe, it seems), my keyboard will slowly stop responding. I figured it was a combination of Synergy (running across two macs), Apptivate, and maybe other apps that used system-wide keyboard shortcuts. It always seems to start with the command key when switching Spaces (letting go of the key doesn't close the spaces overlay). Unfortunately, within 10 minutes, it often devolves into more keys not responding, to the point where I can no longer type into the terminal at all!

Today I just couldn't take "have you tried rebooting?" as the answer anymore, and determined to find the root cause...thanks to this thread, I finally know!!!

If you're not comfortable with Terminal, or like me, have no access to the keyboard at all, here's what I did:

Double click on the hard drive, navigate to Applications > Utilities > Activity Monitor, then sort by name to find the Dock process. Click the quit icon (red octagon), choose "quit" and poof! The dock disappears, and the keyboard works again. The dock will automatically restart, and all should run well (for awhile, at least).

I've had this issue on previous computers as well, and with previous versions of the OS; looks like it's a chronic issue in OSX. Any idea if it's officially recognised by Apple?
 

woo37830

macrumors newbie
Sep 4, 2009
4
0
No this is old, but ...

Under System Preferences, then keyboard, then services there is a turn dashboard on and turn dashboard off service.

Be sure they are there and checked.

Then click on background (desktop) to get finder. Under Finder services select Turn Dashboard On. Shortly it will be turned on and will work fine.

Works for me anyway!
 

InnerSongs

macrumors newbie
Jul 13, 2008
13
0
Clearwater, FL
Command-Tab Failure

I too have the Command-Tab failure.

Tried the 'Killall Dock' command to no avail.

Also tried assigning each program to a Desktop. Nada.

Odd though how much more off than on it is, yet it is intermittent.

My Menus change but the Screen that contains the App remains where it is unless e.g. as in Mail I do a Command-0 to retrieve the message viewer. That takes me over to the proper 'space'.

Well, bound to be some glitches in a Major OS intro. Just kind of surprised with all the testing that such an 'at the surface' function fails.

~S
 

sdpinpdx

macrumors newbie
Jul 28, 2009
1
0
Command-Tab failure - try closing screen sharing

I was just having this problem (Lion). Killall Dock had no effect. There was no ScreenSaverEngine process.

I did have a Screen Sharing window open to another (Snow Leopard) Mac (which was rebooting). Once that was closed, Command-Tab worked again.
 

rauz

macrumors newbie
Dec 13, 2007
6
0
I was just having this problem (Lion). Killall Dock had no effect. There was no ScreenSaverEngine process.

I did have a Screen Sharing window open to another (Snow Leopard) Mac (which was rebooting). Once that was closed, Command-Tab worked again.
Quitting my Screen Sharing session (to a Mac running Lion) solved it for me too.
 

aussiejd

macrumors newbie
Aug 15, 2011
1
0
I was just having this problem (Lion). Killall Dock had no effect. There was no ScreenSaverEngine process.

I did have a Screen Sharing window open to another (Snow Leopard) Mac (which was rebooting). Once that was closed, Command-Tab worked again.
This also solved it for me!
 

onewheelskyward

macrumors newbie
Oct 26, 2011
2
0
Another observation (Lion)

I came to the same conclusion as the last two folks, that it was my Screen Sharing connection that did it. I did, however, make a change to that today.

I set it to default to Observe mode (cmd-opt-X), and I had activated control mode, which apparently steals some function keys as well. Running screen sharing in observe mode doesn't appear to cause an issue for me.

Adding to the list of things to try!
 

woodyofarabia

macrumors newbie
Apr 8, 2011
2
0
command-tab failed in 10.6.4 too; killing dock fixed.

Command-tab failed my new lap-top with OS 10.6.4. Thanks to the above posts I fixed it by killing the dock! Who would have thought. "killall" apparently produced no results but "ps -ef | grep -i dock" identified the dock process that I then killed, and all went back to normal. Thanks !
yup this works well, thanks
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.