Communication with the disc fails

mariano

macrumors newbie
Original poster
Sep 6, 2006
2
0
Hello, I have a new macbook, and sometimes when I insert a cd, it's ejected automatically (Preferences are set right), and sometimes when I get the option to choose the application (ex. finder), and I double click in the cd, it appears the symbol for burning, I must did something wrong before when I tried to burn another cd, and now I click burning and always appear the messagge:
Burning the disc failed because communication to the disc drive failed. Error code 0x80020022.
I would appreciate very much if someone can help me. Thanks.:confused:
 

Frisco

macrumors 68020
Sep 24, 2002
2,475
69
Utopia
mariano said:
Hello, I have a new macbook, and sometimes when I insert a cd, it's ejected automatically (Preferences are set right), and sometimes when I get the option to choose the application (ex. finder), and I double click in the cd, it appears the symbol for burning, I must did something wrong before when I tried to burn another cd, and now I click burning and always appear the messagge:
Burning the disc failed because communication to the disc drive failed. Error code 0x80020022.
I would appreciate very much if someone can help me. Thanks.:confused:
1) Did your Repair Permissions?
2) Is your Computer up-to-date?
3) Did you try a different brand of media?
4) Are you running Norton Anti-Virus? I heard it can cause this error message
 

mariano

macrumors newbie
Original poster
Sep 6, 2006
2
0
Frisco said:
1) Did your Repair Permissions?
2) Is your Computer up-to-date?
3) Did you try a different brand of media?
4) Are you running Norton Anti-Virus? I heard it can cause this error message
I tried diferent brands of media, cd music, (they are ejected), blank cds, etc.
I am not running any antivirus and the macbook is up to date. I don't know what to do. The computer has never been repaired, or going to technical service.
 

shaulzofef

macrumors newbie
Apr 17, 2007
2
0
I've getting the same error exactly, for quite a while now... I've given up. I'm going tomorrow to replace that crapy burner...:mad:
 

zann

macrumors newbie
Sep 23, 2009
4
0
DVDs won't burn due to disc drive error

I had this problem also. A reboot didn't fix it. Used disk utility to fix permissions, that also didn't fix it. Turned off Norton Antivirus, after doing this the very next dvd burned without a hassle.
 

Rizvi1

macrumors 6502a
Mar 29, 2006
801
8
Maryland
I've had my new MacBook Pro (2.4ghz Mid-2010) for a few months now and finally had a need to burn something today. Tried to burn to a Verbatim DVD+R DL Double Layer 8.5gb CD. It got to about 50% and gave me the communication... drive.. something error. going to restart and try again with another disc. The content I'm trying to burn is on a Western Digital external drive connected via a usb cable
 

jordanLA

macrumors newbie
Apr 26, 2011
2
0
0x80020022 Error

After reading numerous posts in many forums on this issue, it seems that the 0x80020022 has been around since at least 2005, and Apple has not directly responded to any reports of it.

It seems to me that Apple wholly ignores this problem, which I am now experiencing on my unibody macbook pro (less than 2years old) and only after upgrading to 10.6.7.

Regardless of media being used (which makes no difference in MOST cases, including my own), and the numerous "solutions" people post in forums which tend to (judging by the responses) NOT WORK, this is a persistent problem.

I believe the best way for Apple to resolve this problem would be a class-action law suit filed o behalf of the hundreds of consumers whose businesses have been affected and enjoyment disrupted, as this seems to be a know defect.

Thoughts?
 

Dana Williams

macrumors newbie
Feb 10, 2019
1
0
0x80020022 Error

After reading numerous posts in many forums on this issue, it seems that the 0x80020022 has been around since at least 2005, and Apple has not directly responded to any reports of it.

It seems to me that Apple wholly ignores this problem, which I am now experiencing on my unibody macbook pro (less than 2years old) and only after upgrading to 10.6.7.

Regardless of media being used (which makes no difference in MOST cases, including my own), and the numerous "solutions" people post in forums which tend to (judging by the responses) NOT WORK, this is a persistent problem.

I believe the best way for Apple to resolve this problem would be a class-action law suit filed o behalf of the hundreds of consumers whose businesses have been affected and enjoyment disrupted, as this seems to be a know defect.

Thoughts?
[doublepost=1549859000][/doublepost]class action lawsuit? Sounds good to me!!!
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.