Compatibility Issue with Final Cut Studio 2?

Discussion in 'Digital Video' started by albertperk, May 18, 2007.

  1. albertperk macrumors newbie

    Joined:
    May 18, 2007
    Location:
    Pennsylvania
    #1
    So I'm getting my FIRST Mac :apple: next month after the MacbookPro update (yay!!) And I was very interested in getting Final Cut Studio 2...but I'm not sure if it would be compatible with my digital camcorder. :confused: I have the Canon ZR-80...I don't know if I should get Final Cut 2 because if it's not compatible with my camcorder, it will be a waste of money...so I'm either getting FCS, or FCS-2 depending on the compatibility...does anyone have any info on this? Thanks guys!
     
  2. zioxide macrumors 603

    zioxide

    Joined:
    Dec 11, 2006
    #2
    Any camera that's compatible with Final Cut Studio (FCP 5.1) will be compatible with Final Cut Studio 2 (FCP6)
     
  3. albertperk thread starter macrumors newbie

    Joined:
    May 18, 2007
    Location:
    Pennsylvania
    #3
    Decent...

    I wasn't sure if there was a difference in compatibility between the two versions or not dealing with that. I may get 5.1 for now and then upgrade later...I'm not sure yet though. Thanks for the info.
     
  4. -DH macrumors 65816

    Joined:
    Nov 28, 2006
    Location:
    Nashville Tennessee
    #4
    The upgrade price from FCS to FCS 2 is $499.00. Might as well go with FCS 2 and save yourself $500.00.

    -DH
     
  5. iMacZealot macrumors 68020

    Joined:
    Mar 11, 2005
    #5
    I use a ZR80 with Final Cut Express and it works fine, and I see no reason why you should get FCS1 over FCS2 unless if you want to throw away a bunch of money. If that's the case, then try the lotto, or just have a bonfire in your backyard... :)

    There's no reason why it should NOT work with FCS2.
     
  6. albertperk thread starter macrumors newbie

    Joined:
    May 18, 2007
    Location:
    Pennsylvania
    #6
    Not a bad idea! I was thinking about that myself actually...haha so kidding...

    Your point is given though. If I decide to do so I'll pony up and get the newest version coming out.

    Thanks.
     

Share This Page