Compilation Version/Firmware

Discussion in 'Jailbreaks and iOS Hacks' started by CKtoph, Jun 18, 2010.

  1. CKtoph macrumors 6502

    Joined:
    Nov 22, 2007
    #1
    I'm probably going to get ripped with the "try the search" for this, but I thought it would be a good idea.

    Could someone post and sticky a list of the versions/basebands/firmwares with a simple O or X for whether it can be unlocked or jailbroken and with what tool?

    I feel like a compilation list of this sort would help prevent so many unnecessary posts (mine included), and it would probably take those of you knowledgable in this regard less than 5 minutes to put such a list together.

    (In my defense, for example, I am trying to figure out whether or not my 3G/3.1.3/05.12.01 can be unlocked, which I don't think it can be without downgrading (if possible?) or waiting for the unlock for iOS4 to be released next week. So, in my scenario, it'd be great to have a reference that I can check to see what my options are to unlock. In my situation, try searching 3G and/or 3.1.3 and/or 05.12.01 and/or 05.12.xx. The results are 1) 14 pages and 2) mostly unrelated.)
     
  2. jlmitnick macrumors regular

    Joined:
    Sep 22, 2009
    #2
    Not a bad idea, although things are likely to look radically different from how they do now in the very near future, what with the iPhone 4 around the corner, the official iOS4 release in a few days, and the anticipated jailbreaks/unlocks.
     
  3. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #3

    Since you have already asked this question, you actually know the answer

    Actually, that has already been done here
     
  4. CKtoph thread starter macrumors 6502

    Joined:
    Nov 22, 2007
    #4
    As for your first point, my question wasn't actually answered if you've bothered to read the thread.

    And for your second, I thank you for the find. As I've clearly indicated, a search of the fields that I chose (3G, 3.1.3, 5.12.xx, etc) did not display such an amazing result.

    I extend my deepest apologies for not being an expert in this regard. I should have completely and utterly devoted myself to the cause as you have obviously done.

    Sarcasm aside, forums are designed for a purpose and if the search does not yield the desired results, a question is in order. I understand you get annoyed with people asking the same questions, but patience is a virtue, especially when all venues were exhausted ahead of time.
     
  5. pixelated macrumors 6502a

    pixelated

    Joined:
    Oct 21, 2008
    #5
    So you got exactly what you wanted with the second reply to your thread...how horrible.

    Just because dhlizard pointed out your double post (which is against the rules) i don't think it warranted such mis-proportioned response, especially as he was the one to help you.
     
  6. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #6
    To be fair, that thread has not been updated to reflect Spirit or 4.0. I probably should update it at some point, but with things changing so fast, I think it's best to wait until we know more.

    I am working up an upgrade guide, though. Its primary purpose is to convince people to wait until they've heard from the Dev-Team.
     
  7. CKtoph thread starter macrumors 6502

    Joined:
    Nov 22, 2007
    #7
    Thank you for the response. And you are 100% right, I think and hope that all will be answered on Monday with the release of iOS4. Hopefully it'll be as simple as upgrade to iOS4 > DevTeam tool > unlock/jailbreak. Maybe I should eat my own words and show some patience, heh.
     
  8. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #8
    MuscleNerd has indicated that if sherif_hashim's exploit is still present in the release version of 4.0 they will be recommending everyone upgrade to the new baseband. I infer from this that they will have an updated version of Redsn0w that will jailbreak all devices on 4.0 and an upgraded ultrasn0w that will unlock the 05.13.04 baseband. I assume that this is why they've been making the betas of Redsn0w 0.9.5 3G-only -- why waste time updating code for the old 3G exploit when you intend to use a whole new exploit in the release version?

    That said, I think that we are likely to see Redsn0w for 3G-only released first, as well as an updated PwnageTool for people who wish to preserve their old baseband and unlock using the current version of ultrasn0w. I imagine they'll take a couple of weeks to test everything and make sure people get their SHSH on file before releasing their new tools. But maybe the Dev-Team will surprise us.
     

Share This Page