Complete reformat of external HDD help

Discussion in 'Mac Basics and Help' started by RedCroissant, Aug 1, 2013.

  1. RedCroissant Suspended

    Joined:
    Aug 13, 2011
    #1
    I have an HP Simple Save external hard drive with a Western Digital SATA HDD in it and every time that I connect the drive it mounts not only the drive; it also mounts an HP Launcher along with it.

    The list in Disk Utility is as follows:

    465.8 GB Hitachi
    Mac2
    465.8 GB Hitachi
    Macintosh HD
    931.5 GB WD(My main drive for media and not the one of concern)
    The Grid
    930.9 GB HP External HDD Media(THIS IS THE DRIVE)
    Untitled
    767.2 MB HP Virtual CD 4607 Media(THIS IS MY MAIN ISSUE)
    disk4s0
    HP Launcher
    PIONEER DVD-RW DVR-110D

    When I select the Virtual CD image, this is what the info says:

    HP Virtual CD 4607 Media
    USB
    External
    767.2 MB
    Read Only
    CD Partition scheme


    Is there a way to completely reformat this HDD to remove that ridiculous HP Virtual CD partition? I was hoping to use this as a boot drive to replace the 500GB drive I have in their as my startup disk, but I don't want the HP Launcher included. Any ideas or advice?

    Thanks in advance!
     
  2. MacUser2525 macrumors 68000

    MacUser2525

    Joined:
    Mar 17, 2007
    Location:
    Canada
    #2
    You want to repartition not format open Disk Utility click on the partition option choosing the HP drive as the drive to be partitioned. Once you have chosen change the scheme from the two it is now to one. Make sure you go into the Options you see at the bottom of the screen to select GUID partition so you can boot into OSX with it using the HFS+ formatted named as you want it, press the apply button and you should be good.
     
  3. RedCroissant thread starter Suspended

    Joined:
    Aug 13, 2011
    #3
    Thanks for the quick response but I just tried it and that didn't work. The HP Launcher and Virtual CD Media is still there.
     
  4. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #4
    Some years ago, when trying to re-initialize a Sandisk flashdrive, I discovered that the flashdrive came from the factory with some software pre-installed that could not be erased by Disk Utility. In effect, it was installed on a protected partition that could not be erased by a Mac. (I'll guess it couldn't easily be erased on a PC, either)

    Since then, I've seen pre-packaged external hard drives that come with pre-installed "management" software. This may or may not be installed on a protected partition. You are going to have to do some further investigation to ascertain if that's the case with the HP drive (actually, that looks to be the case -- hence the "virtual cd" partition that can be read, but not erased).

    In the case of the flashdrive problem I had, I had to search for a utility that could unlock the protected partition, after which it could be erased. Back then, the software was "Windows only" and I actually had to take the flashdrive back to where I bought it, where a PC was available to run the software and unlock the partition.

    You're going to have to do the same. You may be able to find the way to unlock the partition by reading the docs that support the software on that partition. Or you may have to go to HP's site and do some searching. But I'll take a _guess_ that this is the only way you're going to be able to get rid of that partition...


    Aside: this is why I NEVER buy "pre-assembled" drives. I buy "bare" hard drives, and either buy an enclosure and assemble it myself, or get a USB/SATA docking station and mount and use the drive that way...
     
  5. RedCroissant thread starter Suspended

    Joined:
    Aug 13, 2011
    #5
    I was just hoping that I wouldn't have to deal with anything like that at all. That's annoying. And I completely agree with the bare hard drives because that's what I normally do, but I was given this as a gift. Since I can't really spend money on another drive to replace the current ones, I was just hoping to be able to insert this in my PowerMac and be done with it.
     
  6. pastrychef macrumors 601

    pastrychef

    Joined:
    Sep 15, 2006
    Location:
    New York City, NY
    #6
    1. Launch Disk Utility
    2. Highlight the HP virtual CD on the left side of the window
    3. Press Eject at the top of the window
    4. Highlight the 930.9 GB HP External HDD Media on the left side of the window
    5. Select the Partition tab
    6. Click the drop down menu and choose 1 Partition
    7. Click the Apply button
     
  7. RedCroissant thread starter Suspended

    Joined:
    Aug 13, 2011
    #7
    I tried that and that didn't work either. I also called tech support for the drive(since it's a WD drive it directed me to them). They said that they could not help me because it was the customer(HP) that put that partition on there and to simply ignore it if I didn't need it. So the next step is to call HP when I feel like it.
     
  8. pastrychef macrumors 601

    pastrychef

    Joined:
    Sep 15, 2006
    Location:
    New York City, NY
    #8
    Which part didn't work? If possible, please post a screenshot.
     
  9. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #9
    "So the next step is to call HP when I feel like it."

    Reread the explanation I gave to you in reply #4.

    Therein lies your problem, and the pathway towards a solution...
     
  10. pastrychef macrumors 601

    pastrychef

    Joined:
    Sep 15, 2006
    Location:
    New York City, NY
    #10
    Here is the method used to delete partitions like Fishrrman encountered.
     
  11. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #11
    Disconnect all other externals and only attach the troublesome drive. Then in Terminal enter "diskutil cs list" (without the quotes). You will get a listing of every disk and partition on all mounted disks along with the UUID of each volume.

    It will look something like "Logical Volume Group 54DF1D19-281F-46DE-815F-845382E606F2". That long string of letters/numbers is the UUID.

    Scroll through there and note the UUID of the partitions you want to delete. Be very careful you get the correct one as this is not reversible. It sounds like you just want to kill that pesky 767MB one.

    Now run the command "diskutil cs delete 54DF1D19-281F-46DE-815F-845382E606F2" (without the quotes and using your real UUID string from the first cs list command). Do this for each logical volume you want to kill.

    When this is done, start Disk Util and select the drive name at the top and erase the entire disk.

    Again, this is going to wipe any data on the drive.
     
  12. RedCroissant thread starter Suspended

    Joined:
    Aug 13, 2011
    #12
    I don't know if this is normal behavior but instead of dealing with the issue, I decided instead to start cloning drives so that I could eventually get to a higher capacity system. I went ahead and installed the HDD in the PM and when I booted the machine, it didn't recognize the drive and I had to erase it and reformat it as MAC OS Extended and in the APM scheme.

    Now the HP virtual disc doesn't even mount or is shown and I now see the "entire" drive. I'm hoping then that it's all taken care of. I guess we'll see.
     

Share This Page