Completely remove VMware Fusion 6?

Discussion in 'OS X Mavericks (10.9)' started by altjx, Dec 9, 2013.

  1. altjx macrumors member

    Joined:
    May 12, 2010
    #1
    I've been having some issues with my VMware Fusion application freezing certain VMs at random times, causing me to force shut down these VMs.

    That being said, I'm wanting to completely uninstall VMware Fusion 6 from my MacBook Pro (running OSX Mavericks). Just dragging it to the trash folder doesn't seem to do the trick. I want to remove it to where when I re-run the .dmg file, it goes back through the normal installation files.

    I've seen several articles about this, but none seem to be informative enough. Can someone assist me?

    Every time I follow guides on completely uninstalling VMware Fusion 6, I just run the .dmg file and VMware Fusion pops back up like it never went away. VMs and everything still in the library (and yes I've went through the whole ~/Library... etc. file removal stuff.
     
  2. mikecwest macrumors 6502a

    mikecwest

    Joined:
    Jul 7, 2013
    #2
  3. altjx thread starter macrumors member

    Joined:
    May 12, 2010
    #3
    I found it by googling as well. Guess what though? Apparently either that's not completely uninstalling it, or my perception of "completely uninstalling" an application is completely flawed.

    Despite me doing all of what the guide says, me simply clicking on the .dmg file to reinstall VMware again just pops up VMware Fusion Library again within a matter of 1-2 seconds. There's not even another installation wizard like it was during the very first installation. My VMs are still even in the library after following that guide to "completely remove it". Apparently complete removal doesn't include application settings/preferences?

    What am I missing here?
     
  4. Idarzoid macrumors 6502

    Joined:
    Mar 15, 2013
    #4
    Download something like App Cleaner.

    Open the app, drag VMware from Application folder to the window and it should take of everything for you.
     
  5. altjx thread starter macrumors member

    Joined:
    May 12, 2010
    #5
    Thanks for your suggestion. Going to go attempt that now :)
     
  6. mikecwest macrumors 6502a

    mikecwest

    Joined:
    Jul 7, 2013
    #6
    AppCleaner and all the other ones always leave debris behind....

    try using https://www.macupdate.com/app/mac/30079/find-any-file ,

    and searching for vmware , and fusion , delete any debris that it finds left behind....

    It seems like you are trying to re-install, and not having the results that you desire....could this help?

    """

    To remove the old license information:
    Click OK to close the crash report.
    Open Finder.
    On the top menu bar, click Go > Go to Folder. Enter the path below:

    /Library/Preferences/VMware Fusion/

    Delete all files that start with license.fusion.site. by dragging them to the Trash.
    If you are prompted to allow the changes, enter your Mac login name and password, then click OK.
    You can now open and use VMware Fusion. Because Fusion is fully starting for the first time, you must enter your license key or start a trial.
     
  7. altjx thread starter macrumors member

    Joined:
    May 12, 2010
    #7
    Thanks for your suggestion as well. I was able to get it completely reinstalled from scratch (or at least it appeared that way) after a few reboots following the same guide I followed earlier (and the one you linked). Kind of strange, since I've followed it maybe two or three times. After rebooting initially, I found myself having to remove more VMware stuff that apparently got added back, so removing that and rebooting yet again fixed it for me.

    Thanks again for all of the help guys. Going to keep this thread bookmarked in case I run into this with some other apps.
     
  8. mikecwest macrumors 6502a

    mikecwest

    Joined:
    Jul 7, 2013
    #8
    I think what MIGHT have happened is, the background processes for VMware were running, so some of the files could not be properly deleted, so after rebooting after the removal of the background process, you could then remove those files.
     
  9. altjx thread starter macrumors member

    Joined:
    May 12, 2010
    #9
    Ah, yeah. Good point actually. Sounds like exactly what may have happened, since it does happens sometimes.

    Thanks again :)
     
  10. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #10
    If you elect to use such apps, be aware that in most cases, app removal software doesn't do a thorough job of finding and removing files/folders related to deleted apps. For more information, read this and this. If you just want to delete the app, drag the .app file to the trash. No other software needed. If you want to completely remove all associated files/folders, no removal apps will do the job.
    The most effective method for complete app removal is manual deletion:
    Step 1 of those instructions is to make sure the app being removed isn't running. In some cases, if you quit a process, it relaunches automatically. The way to correct this is to check the following locations for apps that automatically launch on startup and delete any you don't need/want:
    • System Preferences > Users & Groups > yourusername > Login Items (SL and older: System Preferences > Accounts > yourusername > Login Items)
    • In Finder, click Go > Go to Folder > /Library/LaunchAgents
    • In Finder, click Go > Go to Folder > ~/Library/LaunchAgents
    • In Finder, click Go > Go to Folder > /Library/StartupItems
    Next, restart your Mac and the app won't be running. Now you can proceed with the steps in the link above.
     
  11. dyn macrumors 68030

    Joined:
    Aug 8, 2009
    Location:
    .nl
    #11
    The above mentioned "manual delete" does not fully delete either. This is due to the fact that you search for files with a certain name in them as do all those app cleaner apps. Software builders may name parts of their application differently. This is because they have a foundation that they use for all or some of their apps. VMware is a good example of the latter (the code in Fusion, Workstation, ESXi, Player is the same for about 90%). In some cases it's because they bought up some company and didn't change the naming of files (SourceTree is a good example of that).

    The only way to fully uninstall an app is when the maker gives you detailed instructions where they put files when the app was installed and what you need to remove. Unfortunately not many do it this way. VMware does this, see the aforementioned KB article. The best way to do this is via the commandline. The OP may have overlooked some of the files to delete. As of Fusion 4 (if I recall it correctly) nearly all of it is inside the application itself (thus "VMware Fusion.app"). Only some of it will be outside it. When you have made sure all of the listed folders and files are deleted you may want to reboot to make sure nothing is left and everything is unloaded. This way of uninstalling is somewhat similar to their instructions for Fusion 3.x.

    The reboot afterwards is a very crucial thing as of Mavericks. Mavericks will cache plists that are in the Preferences folder. You reload the cache by rebooting (you could do this manually to by doing a "killall -u $USER cfprefsd" on the commandline but it may be necessary to restart some more components. The quickest and easiest way of doing that is rebooting.
     

Share This Page