Completely screwed up my fonts... HELP! :(

Discussion in 'OS X Mavericks (10.9)' started by Uplift, Oct 24, 2013.

  1. Uplift macrumors 6502

    Joined:
    Feb 1, 2011
    Location:
    UK
    #1
    I updated to Mavericks yesterday, before doing this i backed up my fonts by going into Font Book, right clicking my User collection and exporting it...

    After the install i went back into Font Book and dragged my User folder into Font Book... i'm assuming this was a big mistake.

    It started throwing errors about duplicates and lots of fonts were disabled. Every font went into the All Fonts / Computer collection and not into a User collection as i expected.

    I'm now left with an absolute mess so i attempted several things like getting font book to fix duplicates and errors and also tried 'restore standard fonts'

    Nothing seems to work and now photoshop is completely borked... Any file i try to open it gives me an error:

    Selected font failed during last operation. If Problem persists, please disable the font.

    If i try to start a new document it says:

    Could not complete your request because something prevented the text engine from being initialized.

    I've got clients bugging me for work and i can't do any of it.

    Any suggestions here? I'd love to be able to go back to the original settings (before i touched font book) then just start adding fonts manually.
     
  2. guitarman777 macrumors regular

    guitarman777

    Joined:
    Sep 15, 2005
    Location:
    Orlando, FL
    #2
    Did you do any kind of a complete backup of your system before dragging in the User folder? I hope?...
     
  3. pencilcheck macrumors member

    Joined:
    Sep 2, 2010
    #3
    If you open Font Book app, go to the File menu and you should be able to see an menu entry to "Restore Standard Fonts", try and see if that would fix the problem for you.
     
  4. benwiggy macrumors 68020

    Joined:
    Jun 15, 2012
    #4
    If you did a standard install, then there was no need to re-import the fonts. All your data, apps, fonts and settings should have been kept.
    So you may have added duplicates to the existing font libraries.

    Check FontBook for duplicates. There is a command for this. Mavericks installs lots of fonts, including some new versions of older fonts. It disables the older versions.
     
  5. Uplift thread starter macrumors 6502

    Joined:
    Feb 1, 2011
    Location:
    UK
    #5
    I did a clean install so all my fonts were deleted. I've tried "Restore Standard Fonts" and it does nothing.
     
  6. benwiggy macrumors 68020

    Joined:
    Jun 15, 2012
    #6
    If you did a clean install, then you should have a backup from which to restore everything. The Setup Assistant should run when you first launch the computer, and you can point it at your TM archive or other external clone.
    No need to do it manually.

    Have you added any fonts yourself to your user folder (or system) other than the ones that come with OS X? If not, then don't reinstall anything.
    If you have loads of fonts in your user font library, you should be able to just drag and drop them back. If you are still getting problems after doing that, then something else may be at work: corrupt disk; corrupt font files.
    Are these PostScript Type 1 fonts? Did you back them up onto a non-HFS+ volume?
     
  7. PFPhoto macrumors newbie

    Joined:
    Mar 4, 2015
    #7
    just to say it did work for me. Many many thanks to pencilcheck!
    Shouldn't ADOBE care to be the first one to solve this problem and spread the word? Nah, too much to ask to a gigantic market leader....
    :p
     

Share This Page