Computer Crashing - MSWorker?

Discussion in 'Mac Basics and Help' started by iphigeneia5, Sep 1, 2013.

  1. iphigeneia5 macrumors newbie

    Sep 1, 2013

    I have a 2011 MacBook Pro, and I am running Lion (10.8.4), though this problem began when I was running Snow Leopard (10.6.8, I think?).

    My computer used to work quite well, then, with no provocation, videos stopped working. YouTube, Netflix, Amazon Prime, and even videos I downloaded to watch with VLC. The videos would become progressively more and more choppy with audio choppiness as well. I enlisted the help of a friend who is much more tech savvy than I, and he noticed that my CPU usage was skyrocketing whenever I would try to play videos (we also noticed this whenever I would try to run any of the software I need for my research). The culprit? A program called msworker or mdworker (if I remember correctly); it would hog huge percentages of my cpu even when the computer was idle. We tried fix after fix, disabling spotlight, etc., and nothing worked.

    I thought to wipe the computer and put Ubuntu on it, since most of my research software runs better with Ubuntu anyways, but my computer spits out any disk I put in (new development), and also refused to recognize the USB I formatted.

    Last night, I upgraded to Lion. I tried to play a video on it via Netflix and the entire computer crashes to gray screen. When I report the error, this is what it says:

    Interval Since Last Panic Report: 5021 sec
    Panics Since Last Report: 2
    Anonymous UUID: 95734D7B-7FB4-84B6-B690-F4A71E671ECA

    Sun Sep 1 17:49:55 2013
    panic(cpu 1 caller 0xffffff8002eb8655): Kernel trap at 0xffffff7f84567f64, type 14=page fault, registers:
    CR0: 0x000000008001003b, CR2: 0x000062696c7b8e4e, CR3: 0x0000000010763000, CR4: 0x0000000000000660
    RAX: 0x000062696c79642e, RBX: 0x00000000000002a0, RCX: 0x94af7b2de7e40095, RDX: 0xffffff80758ad078
    RSP: 0xffffff807bb23810, RBP: 0xffffff807bb23850, RSI: 0xffffff80758ad068, RDI: 0x0000000000000001
    R8: 0xffffff8075855078, R9: 0x00000000009886df, R10: 0xffffff807bb23690, R11: 0x00000000ffffff80
    R12: 0x00000000000002a1, R13: 0xffffff8013f4f000, R14: 0xffffff807bb23868, R15: 0x0000000000000000
    RFL: 0x0000000000010286, RIP: 0xffffff7f84567f64, CS: 0x0000000000000008, SS: 0x0000000000000010
    Fault CR2: 0x000062696c7b8e4e, Error code: 0x0000000000000000, Fault CPU: 0x1

    Backtrace (CPU 1), Frame : Return Address
    0xffffff807bb234b0 : 0xffffff8002e1d626
    0xffffff807bb23520 : 0xffffff8002eb8655
    0xffffff807bb236f0 : 0xffffff8002ece17d
    0xffffff807bb23710 : 0xffffff7f84567f64
    0xffffff807bb23850 : 0xffffff7f845780d4
    0xffffff807bb238a0 : 0xffffff7f845439bb
    0xffffff807bb23a20 : 0xffffff7f84573f0f
    0xffffff807bb23ae0 : 0xffffff7f845418c8
    0xffffff807bb23b30 : 0xffffff8003266e69
    0xffffff807bb23b50 : 0xffffff8003268410
    0xffffff807bb23bb0 : 0xffffff8003265e2f
    0xffffff807bb23d00 : 0xffffff8002e98c01
    0xffffff807bb23e10 : 0xffffff8002e20b3d
    0xffffff807bb23e40 : 0xffffff8002e10448
    0xffffff807bb23e90 : 0xffffff8002e1961b
    0xffffff807bb23f00 : 0xffffff8002ea63de
    0xffffff807bb23fb0 : 0xffffff8002ece78e
    Kernel Extensions in backtrace:[7EC545A4-4B57-32F1-8DC3-C31023AFBDCB]@0xffffff7f8452f000->0xffffff7f845fcfff

    BSD process name corresponding to current thread: Google Chrome He

    Mac OS version:

    Kernel version:
    Darwin Kernel Version 12.4.0: Wed May 1 17:57:12 PDT 2013; root:xnu-2050.24.15~1/RELEASE_X86_64
    Kernel UUID: 896CB1E3-AB79-3DF1-B595-549DFFDF3D36
    Kernel slide: 0x0000000002c00000
    Kernel text base: 0xffffff8002e00000
    System model name: MacBookPro7,1 (Mac-F222BEC8)

    System uptime in nanoseconds: 247268601345
    last loaded kext at 96710107430: com.bresink.driver.BRESINKx86Monitoring 9.0 (addr 0xffffff7f85039000, size 16384)
    loaded kexts:
    com.bresink.driver.BRESINKx86Monitoring 9.0
    com.avatron.AVExFramebuffer 1.7
    com.avatron.AVExVideo 1.7 3.10 1.60 1.9.5d0 100.12.87 1.0.2d2 3.0 2.3.7fc4 2.3.7fc4 122 2.3.7fc4 3.5.10 1.0.0d1 4.1.4f2 7.0.0 3.4.5 8.1.2 1.0.0 1.6.0 2.0.3d0 3.4.5 170.2.5 1.1.11 8.1.2 3.0.3d1 237.1 320.15 3.0.1 1.0.0d1 1.0.0d1 34 237.1 237.1 3.1.7 3.5.5 404 2.3.1 3.6.1b4 615.20.17 5.5.5 4.9.6 2.5.2 5.5.0 5.2.5 161.0.0 1.7 1.5 1.8 1.7 1.9 1.7 1.6 196.0.0 4.0.39 2.1 196.0.0 1.0 2.3.7fc4 1.8.9fc11 1.6 86.0.4 10.0.6 4.1.4f2 1.0.11d0 2.2.5 8.1.2 8.1.2 2.3.7fc4 2.3.7fc4 1.0.0 5.3.0d51 3.4.5 1.0.4 1.0.11d0 2.3.7 2.3.7 3.1.4d2 237.3 5.2.5 3.5.5 3.5.1 5.5.5 5.2.5 3.5.5 1.7 1.7.1 1.7.1 2.5.1 3.5.5 1.0.2b1 530.4 3.0 5.5.5 4.5.5 1.11 2.3.1 5.6.0 2.2.9 1.7 1.8.1 1.1 220.3 1.0.0d1 7 345 1.8 28.21 1.7 2.7.3 1.4 1.0
    Model: MacBookPro7,1, BootROM MBP71.0039.B0B, 2 processors, Intel Core 2 Duo, 2.4 GHz, 4 GB, SMC 1.62f7
    Graphics: NVIDIA GeForce 320M, NVIDIA GeForce 320M, PCI, 256 MB
    Memory Module: BANK 0/DIMM0, 2 GB, DDR3, 1067 MHz, 0x80CE, 0x4D34373142353637334648302D4346382020
    Memory Module: BANK 1/DIMM0, 2 GB, DDR3, 1067 MHz, 0x80CE, 0x4D34373142353637334648302D4346382020
    AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x8D), Broadcom BCM43xx 1.0 (
    Network Service: AirPort, AirPort, en1
    Serial ATA Device: Hitachi HTS545025B9SA02, 250.06 GB
    Serial ATA Device: MATSHITADVD-R UJ-898
    USB Device: Internal Memory Card Reader, apple_vendor_id, 0x8403, 0x26100000 / 2
    USB Device: IR Receiver, apple_vendor_id, 0x8242, 0x06500000 / 3
    USB Device: Apple Internal Keyboard / Trackpad, apple_vendor_id, 0x0236, 0x06300000 / 2

    I'd appreciate any help anyone can offer!

    Thanks :)
  2. MacForScience macrumors 6502


    Sep 7, 2010
    How often is your computer panicing?

    Have you tried a full wipe and re-install?

    I would run Apple Hardware Test.

    I would also run Disk Utility and verify permissions.

    I would also verify the disk, by booting to the recovery partition, and using Disk Utility there.

    If mdworker is hogging your resources, then that is spotlight. Does spotlight constantly re-index your hard drive, or fail to find files?

  3. Weaselboy Moderator


    Staff Member

    Jan 23, 2005
    Often that last kext loaded is a tip where the problem is. Check this out.


Share This Page