Computer failing, Back up /users with Terminal, thank you!

Discussion in 'Mac Basics and Help' started by swingerofbirch, Jan 14, 2013.

  1. swingerofbirch macrumors 68040

    Oct 24, 2003
    The Amalgamated States of Central North America
    I've been having a lot of problems with my MBP 13" running 10.8.2.

    It often won't start up (flashing question mark/do not enter sign). It often will stop working altogether with a beachball for a few minutes and then come back to life. And sometimes it will just stop responding altogether and have to be turned off. Recently sometimes when it starts up white text on a black background cascades down the screen (not the you must turn off your computer message, but more random UNIX stuff).

    However, I *can* after some trying turn it on and log-in and some applications still work, while others like iPhoto or EvoCam won't open. All my files seem to be there.

    Right now my main goal is to back-up my data to an external USB 3 disk formatted in Mac OS Extended Journaled. I tried using SuperDuper, and every time it would fail listing a specific file that could not be copied (each time it would be a movie file in the iPhoto library).

    So, I then enabled the root user, logged into that, and tried dragging and dropping the Users folder to the external drive. It would take a really long time (estimated time "one day" to transfer 650 GB) and each time I tried it would stop with an Error -36 Input/Output error listing a specific file that could not be written or read (sometimes an iPhoto movie, sometimes a movie I had recorded with EvoCam located on the desktop). I would find that individual file and try dragging and dropping it to the external disk and it worked fine! I would then try dragging the Users folder again, and it would stop on a different file after copying for hours and again that individual file would transfer if I moved it by itself but not the entire folder.

    Each time it stopped copying, it didn't continue without that file; it would stop altogether, and not even leave what it had already started to copy.

    Everything I've researched about this says that Error -36 was more common with Snow Leopard and people transferring to FAT 32 disks, which I am not doing. I am on Mountain Lion transfering to a Mac-formatted disk.

    However, one recommendation with Error -36 was to try copying the Users folder using Terminal. I have tried researching how to do this, but I don't want to do it until I get feedback that I would be doing it right.

    From what I understand, I would use the copy command like this:

    cp -rv Users "External Drive"

    And from what I understand I would drag and drop the users folder into the Terminal to get the right directory listing (something like "Macintosh HD/Users" I'm guessing), and I would do the same for the External Disk, using quotation marks around it, since it contains spaces.

    I would use -r because I want it to copy everything inside Users. Would it also copy files inside the iPhoto Library, which I believe is a package? And I believe I would also use -v so that I can see it is copying files and have some update rather than waiting for several hours and not knowing what's happening.

    So, I'm really sorry for the long story, but if someone in the know would be so kind as to respond, do you think this is the right tactic? Are those the right commands to try? Should I run them from the root user so that I'm not actively using the Users folder as it copies? Would it copy my library files over even though they're invisible?

    I tried calling Apple, but as you can imagine, they told me I need to erase the hard drive and if I can't I could bring it into an Apple Store to have it erased--how helpful! I'm not sure why that's what they go to first when I obviously want to recover the data and I haven't exhausted my options.

    OK, thank you VERY much for your help!

    EDIT: Forgot to mention: I have run disk utility both from the computer live and from the Internet Recovery system (starting up with command-R), and it reports no problems on either the internal or external disk when verifying the disk. I have repaired disk permissions on the internal disk. I have run the hardware test twice, and it found no problems.
  2. Stooby Mcdoobie, Jan 14, 2013
    Last edited: Jan 14, 2013

    Stooby Mcdoobie macrumors 6502a

    Stooby Mcdoobie

    Jun 26, 2012
    You don't need the quotes if you're dragging the directory to Terminal because it automatically adds the necessary escape character(s) '\' to negate the space(s). You would use quotes if you were manually typing the directory.

    cp -rv Users /Volumes/External\ HD
    Is similar to what you'll see with the drag/drop method.

    cp -rv Users "/Volumes/External HD"
    Is equivalent to the first.
  3. blueroom macrumors 603


    Feb 15, 2009
    Toronto, Canada
    Here's what I'd do.

    Swap the drive with something new, reinstall OSX, put the old drive in an external USB case and try pulling off important files onto the new OS.

    Futzing with a dying drive will only speed up its demise.

    Also start using Time Machine or Dropbox if you value your data.
  4. justperry macrumors G3


    Aug 10, 2007
    In the core of a black hole.
    There was a User here with the exact same problems as you have here, your Install is OK, the problem is your iPhoto Library.

    It's a while ago, probably a couple of weeks ago he posted this, can't really remember what solved his problem.
    He always got kernel panics when using iPhoto and got into the same boot problems.

    I tried to find the thread but can't find it.

    Do you happens to have filevault enabled and a SSD, somehow I also have this in the back of my head.
  5. swingerofbirch, Jan 15, 2013
    Last edited: Jan 15, 2013

    swingerofbirch thread starter macrumors 68040

    Oct 24, 2003
    The Amalgamated States of Central North America
    Thanks for the help everyone. Writing from my iPod now as I'm letting terminal run and its working. The iPhoto library is the biggest component at 500 gb. I'm watching files copy and while they are copying which they didn't from finder, it's copying my iPhoto files from user directory/library/containers/ library (it goes on) and its copying them to the same directory on the external disk ... The pictures folder on the external disk hasn't even been created yet though over 400 gb has been transferred. Not sure what will happen when it gets to the pictures folder as the external disk is only 750 gb. I will just let it keep running since its the only thing that has sort of worked. But if it hasn't ill take your advice of trying the external enclosure

    I thought this would be good practice typing on iOS but it's maddening

    Thank you for all your advice so far everyone

    No ssd or FileVault

    EDIT 2:
    I figured out that for whatever reason, my library folder, and maybe it is supposed to be this way, had symbolic links all throughout each container folder to my home directory folder (pictures, desktop, etc).

    I figured out that the "-r" command copies the actual data rather than copying the link, but there is another command "-R" (the only difference being the capitalization) that copies the symbolic link and not the content.

    The backup seemed to work!

Share This Page