Computer Freezes and Keyboard sticks sometimes - Re-install Leapord?

Discussion in 'MacBook Pro' started by qsch, Sep 15, 2010.

  1. qsch macrumors newbie

    Joined:
    Mar 24, 2010
    #1
    Hello I am having problems with my macbook pro which i bought about 2 years ago. The first time since I have this computer.

    Sometimes it freezes, including the mouse then I need to push the power switch and reset it. Also sometimes when I type words it doesnt register (the letters do not come up). I dont know what to do but I am thinking that I should reinstall the Leapord. Can I do that without loosing programs? Also is it maybe a hardware problem such as the keyboard itself?

    Thanks in advance!
     
  2. mr.steevo macrumors 65816

    mr.steevo

    Joined:
    Jul 21, 2004
    #2
    Hi,

    Do you have any peripherals connected to the Macbook? wired mouse?

    Have you added RAM lately?

    Did you drop it?

    s.
     
  3. bamf macrumors 6502

    Joined:
    Feb 14, 2008
    #3
    Does this happen during periods of high CPU activity on the machine, or just randomly?

    You can check the CPU utilization with Activity Monitor. Be sure to choose "All Processes" to see if there may be an errant process using unusual amounts of CPU time.
     
  4. got2go macrumors member

    Joined:
    Jul 23, 2010
    #4
    sounds like your HDD is going bad. Check it out with techtools if you have apple care (its a download from support on apple.com) or just make sure all your data is backed up.

    I had those same symptoms twice and when i ran techtools it showed disk errors and i needed to have my HDD replaced both times.
     
  5. qsch thread starter macrumors newbie

    Joined:
    Mar 24, 2010
    #5
    Hey you all thanks for your answers. To your questions:

    I dont have apple care so can't get techtools. Is there another way to test my HDD or is there another program I can use such as techtools?

    I checked the activity monitor and the red line showing written data is very high at certain intervals. It says that there are 70 processes and 296 threads. I also tried stopping some of the processes/programs however it seems that some of them relate to the computer operating system functioning properly so dont want to delete any unless I know I can without problems. Is there a way for me to find out that?

    In relation to peripherals and additional ram, I did not add any.

    Just writing this reply to you all every second or third sentence some letters I typed did not load and I had to go back and type them again. It is really annoying and I am appreciating all of your assistance!

    Best, QSCH
     
  6. qsch thread starter macrumors newbie

    Joined:
    Mar 24, 2010
    #6
    So I re-installed Leapord anyway and everything is working fine except the slow keyboard. So I am not sure if I need a firmware as apple seemed to have a problem from before regarding the keyboard or should do I have to change the keyboard hardware whatever it is called? I am lost.
     
  7. mr.steevo macrumors 65816

    mr.steevo

    Joined:
    Jul 21, 2004
    #7
    If you have a desktop keyboard available to you, plug it in to your MBP and test the typing speed. Does it still delay?

    As for checking your HDD, there is Smart Reporter but I am not sure how effective these utilities are. I had a hdd that I knew was failing yet Smart said everything was fine. Maybe the software has improved.

    Finally, does your MBP have the removable keyboard or is it the unibody chicklet style? I just wonder if there are crusties under the keys that are causing the delay problems.
     
  8. Sun Baked macrumors G5

    Sun Baked

    Joined:
    May 19, 2002
    #8
    If the above smart app shows you errors and bad sectors on the drive use it, please.

    or http://download.cnet.com/SMART-Utility/3000-2248_4-146625.html?tag=mncol

    ---

    Freezes on the machine are worrying, since a dying drive with bad sectors and increasing errors will freeze the system really hard -- usually even the clock stops and the only thing moving is the mouse.

    Generally you should see no bad sectors, and very few errors if any.

    NOTE: using disk utility to see if it passes SMART is a fools errand, Apple replaced my drive even though it passed, usually it fails the drive only when data is long past saving or the drive is a brick.
     
  9. qsch thread starter macrumors newbie

    Joined:
    Mar 24, 2010
    #9
    So I downloaded the smart application and there seems to be no problem with the hdd. Since I re-installed Leapord I have been having no feezes. The problem was with the typing. I did some research into that after which I found out how to take off the keys. It was very clean below the keys, however to my amazement (even though I have a plastic key cover), there were maybe about 5 - 10 hair below some of the keys. I pulled them out and since I haven't had any problems with the keys sticking (loading slow). Who would think that the keyboard is so sensitive?

    So what happened was a bit of an evil circle situation. The keys caused the problem. I thought the system was overloaded and cleaned some files. Then the freezes started happening after which I re-installed leapord and after lots of research checked the keys to find that the main source of the problem was the tiny hair under some of the keys....

    The last few days I have been enjoying :( re-installing all my programs. I am lucky enough not to have lost any major files as I have everything backed up on my time capsule.

    Thanks Guys and Girls.
     
  10. bamf macrumors 6502

    Joined:
    Feb 14, 2008
    #10
    Glad it's working now.
     
  11. qsch thread starter macrumors newbie

    Joined:
    Mar 24, 2010
    #11
    Hey so it worked perfect and now the problem started again. I have researched a bit and some people who have had similar keyboard glitches suggest that the top case or logic board may be bad! Any ideas?
     
  12. shoebobs macrumors regular

    Joined:
    Jul 5, 2008
    #12
    There are a lot of discussions on the apple support pages saying the problem may have to do with the battery/keyboard ribbon cable. here's just one thread - http://discussions.apple.com/thread.jspa?messageID=7284240#7284240

    Try plugging an external mouse keyboard into the machine, but only use the trackpad/MBP keyboard. Once it freezes or is nonresponsive, test if you can use the external peripherals. If those work and the trackpad/MBP keyboard do not, it may be the same issue others are seeing on the apple support forums.
     
  13. qsch thread starter macrumors newbie

    Joined:
    Mar 24, 2010
    #13
    When looking at it it seemed the keyboard ribbon cable was a bit out of the slot, so I tool it out wiped it and put it back in. Let's see if it is going to stop giving trouble. It has been fine since then!

    Also the part between my trackpad and the spacebar seems raised up a bit more than the rest of the cover on the left and right. Is this Normal.

    Thanks in advance!
     
  14. snaky69 macrumors 603

    Joined:
    Mar 14, 2008
    #14
    Sorry if I am of no help, but I could not help myself seeing your misspelling Leopard consistently throughout your thread.


    It does indeed sound like a hard drive about to die. I would backup using an external drive and time machine, and either find a way to test the drive yourself or bring it in for repairs.

    I would try first with disk utility(type it in spotlight, it'll be the first result) click your hard drive on the left, and then verify the disk. If all checks out, you can always try other utilities, or Apple's diagnostic software(insert the OS X DVD that came with your machine, reboot, and press D down, let it do it's thing, it takes about an hour).
     
  15. qsch thread starter macrumors newbie

    Joined:
    Mar 24, 2010
    #15
    Hey Snaky, Thanks for your response. I did use disk utility already and this program I was recommended the smart reporter and so far I have not had any serious errors. I was told higher up in this thread that disk utility is not that reliable and that smart reporter is better. I think the idea to test through Apple's diagnostic software is a good one, although since I have taken out the keyboard ribbon cable and pushed it back in further I have not had a problem. It is working perfectly again! Let's hope it stays that way, and thanks for your advice in relation to the correct spelling of Leopard. I did realize that something sounded wrong but couldn't ask checking if the alternative option with the A and O switched around was right ;).

    I will keep you guys up-to-date to let you know if the ribbon cable was the cause! Best, Q

    PS: All my files are backed up with Time Capsule...
     
  16. qsch thread starter macrumors newbie

    Joined:
    Mar 24, 2010
    #16
    SO I think you are totally right! More and more of my research is pointing to the ribbon cable butterfly cable (a hardware design issue). It usually gives me no problem when the battery is out of the computer but seems when it is inside the keyboard gives me problems (sometimes).

    I am not sure if it is because it squeezes the cable (which is located below the battery) or because of the heat around the battery. Do you know any solution for that issue? I looked in the posts but there isn't really anything straighforward to solve the problem. Looking at the cable it seems it doesnt fit or push properly into the slot (I guess when the battery squeezes the connection gets bad).

    About 20 minutes ago it started giving me problems again (glitches while I was typing) and after removing the battery now it works fine (the battery is here laying on the couch next to me). But I am not sure what to do to rectify the problem.

    Thanks for your help!
     
  17. snaky69 macrumors 603

    Joined:
    Mar 14, 2008
    #17
    Hopefully it was just the cable, that's a much cheaper fix :) Keep an eye on that hard drive still, it can't hurt to check. Glad to hear the problem went away.

    Kind of odd that it would work itself loose though.
     

Share This Page