Computer Not Authorized after Jailbreaking

Discussion in 'iPod touch Hacks' started by icefall5, Mar 6, 2011.

  1. icefall5 macrumors newbie

    Joined:
    Mar 6, 2011
    #1
    I jailbroke my iPod Touch 4G a few days ago, and I'm trying to sync it with iTunes for the first time since.

    When I try to sync, I get a message saying "This computer is no longer authorized for apps that are installed on the iPod "(name)". Would you like to authorize this computer for items purchased from the iTunes Store?" If I click the Authorize button and enter my password, a new box pops up saying "This computer is already authorized." As soon as I click OK on that box, the original box pops back up saying it's not authorized. I have to cancel the sync in order to stop the loop.

    I tried to manually deauthorize and reauthorize the computer, but that didn't stop the messages from appearing. I just installed iTunes 10.2, but I've seen on other websites that people had this issue before updating. I'm running 4.2.1 and I jailbroke with greenpois0n rc6.

    Any help would be appreciated!
     
  2. LegendKillerUK macrumors 6502

    Joined:
    Apr 9, 2010
    #2
    I had this ages ago back in the 2.x days. Pretty sure an iTunes reinstall fixed it for me.
     
  3. icefall5 thread starter macrumors newbie

    Joined:
    Mar 6, 2011
    #3
    Uninstall/reinstall did not fix it for me, nor did a repair from Control Panel.
     
  4. Crigger540 macrumors member

    Crigger540

    Joined:
    Jun 16, 2010
    Location:
    The Old Dominion
    #4
    might need a new iPod.
     
  5. ghostlyorb macrumors 6502a

    ghostlyorb

    Joined:
    Jan 9, 2010
    Location:
    Virginia, USA
    #5
    haha... try restoring the iPod?
     
  6. morean51 macrumors newbie

    Joined:
    Mar 6, 2011
    #6
    might go with uninstalling your itunes application or go fix your ipod touch by updating with latest firmware
     
  7. icefall5 thread starter macrumors newbie

    Joined:
    Mar 6, 2011

Share This Page