computer 'reset' itself, no files missing, can't open anything - it's an emergency

Discussion in 'Mac Basics and Help' started by IniquityBliss, Jul 31, 2008.

  1. IniquityBliss macrumors newbie

    Joined:
    Jul 31, 2008
    #1
    I have a MacBook 13" 2.0 GHz Intel Core 2 Duo 10.4.11
    I am a medical student and I have 9 MAJOR exams beginning within the next 7 days.

    I force quit parallels (I have since learned not to do this). After the force quit parallels wouldn't open anymore and told me that it was in use by another application. I found a parallels support page and went to Terminals and typed the path to the winxp.hdd file (which i did correctly) and then I typed chmod 666 and it didn't work. so i just typed in chmod 666* (i didn't put in the path again). this did not fix the problem with parallels. however, i found this support page from parallels - telling me to delete the .lck file - and it did work (http://kb.parallels.com/en/4938). parallels was running again but i was running into other problems with other applications telling me i didn't have permission to open them. i went into disk utility and did 'repair disk permissions'. i thought that solved the problem (it didn't).

    Because i thought the problem was solved and everything was just fine i downloaded a driver for our campus printer - which came from the manufacturer's website found here (http://www.ricoh-support.com/enduse....com/bb/html/dr_ut_e/re/model/mp90/mp90en.htm). The PDD Installer for version 10.4 didn't seem to do anything so i downloaded the one for 10.5.
    I then noticed that firefox wasn't working very well and eventually wouldn't open at all (it just bounced in the dock). I also noticed that every other program was doing the same thing.
    I decided that it would be best for me to just restart my computer. Things have now worsened. I can't open skype because of some permission thing, my dock looks like it did when my computer came out of the box and so does dashboard, nothing will open (word, excel, powerpoint), itunes shows me the user agreement when i open it as though it's being opened for the first time, shrook (rss reader) opens but all the rss feeds that i had subscribed to are gone, safari opens but i keep getting this damn popup about some keychain issue, but all of my files are still present on my desktop in their little folder (they just won't open because none of the applications will open).
    I had already backed up 90% of all files on an external hard drive and the rest I can get from a shared drive.

    I am 3000 miles from my home Apple store and currently in a country that does not have one at all, I cannot e-mail them because they don't do e-mail tech support and 1-800 numbers only work if you are in the US so I can't call them because I don't have a direct number to Apple. I have a backup iBook but I really need to be able to run parallels. My stress level probably just set a world record.

    Please help me.
     
  2. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #2
    Have you verified your computer's disk? There are three ways to do this:

    1. Boot the Mac off of another drive, if you have one - the Mac OS X install disc works well for this purpose, as does any bootable backup, then run Disk Utility and click Verify Disk.

    2. If you have two Macs handy, and a FireWire cable, boot the troublesome Mac into FireWire Target Disk Mode, and use the second Mac to remotely diagnose it.

    3. If neither of those are options, then you can boot the troublesome Mac into Single-User Mode, and run some UNIX commands to check your disk.
     
  3. macmikey2 macrumors regular

    macmikey2

    Joined:
    Jul 6, 2008
    Location:
    West Chester, PA
    #3
    Sounds like a corrupted user

    Sounds like a corrupted user.

    Try this first, then we can try something else.

    Shut down not restart your Mac. Power back on and hold shift key to boot into single user mode. Keep shift key down until you see it is booting up.

    Wait for it to finish booting. It can take a VERY long time so be patient with it.

    When it finishes booting and you have logged in, do nothing but shutdown again. Booting into single-user does some magic and cleanup.

    Reboot again and log in normally. See if this helped. If not, we can try to create a new user and see if the apps behave normally. If they do, then your user is bad and you can move stuff over to new user and delete the old one.

    Hope this helps,
    Mike
     
  4. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #4
    The process you described is not "Single-User Mode" but rather "Safe Boot". It does do some cleanup, as you mentioned.
     
  5. macmikey2 macrumors regular

    macmikey2

    Joined:
    Jul 6, 2008
    Location:
    West Chester, PA
    #5
    Good call. I was thinking of something else while i typed.

    Mike
     
  6. IniquityBliss thread starter macrumors newbie

    Joined:
    Jul 31, 2008
    #6
    thank you both for your rapid replies. i shut down the computer and will be home from class in a couple hours. i'll post again after i try your suggestions.
     
  7. IniquityBliss thread starter macrumors newbie

    Joined:
    Jul 31, 2008
    #7
    I tried Safe Boot but no luck.

    I do not have a FireWire cable and I don't have another drive that I can boot from.

    I'm willing to go into Single-User Mode but I don't know how to do that or what to do once I get there.
     
  8. aross99 macrumors 68000

    aross99

    Joined:
    Dec 17, 2006
    Location:
    East Lansing, MI
    #8
    I think the issue may be caused by your "chmod 666 *" command. That sets the permissions of everything in the directory you were working in, to "read/write" and strips the execute permission. It has other effect on folders as well.

    This was probably NOT what you wanted to do, and depending on where you were when you did this, it would seem like it would cause a number of serious issues - especially if you were in your Applications folder...

    How about you try to repair permissions in Disk Utility. This will set the permissions of Apple installed applications (and others?) back to what they should be, and may help some of your issues.
     
  9. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #9
    Try repair permissions.

    Do not do any terminal command that you don't know anything about (including only portion of command for example)

    BTW, if I am overseas, and need to reach a US number, I use skype or something similar.
     
  10. pooky macrumors 6502

    Joined:
    Jun 2, 2003
    #10
    Agreed. Although it sounds like the OP tried repairing permissions, and it didn't work.

    To the OP - do you remember what directory you were in when you ran the chmod 666 * command? Did you type cd followed by a pathname first?

    Try this: open your terminal, then type

    ls -al

    Select the output with your mouse, then paste it into a post. I suspect you took away execute permissions for your Library folder, which might explain the odd behavior of your applications - for directories, the execute bit controls the permission to move through the hierarchy. Take it away from Library, and no apps will be able to get in there to write preferences. If I'm right, the command above will show it, and it should be easily fixed.
     
  11. aross99 macrumors 68000

    aross99

    Joined:
    Dec 17, 2006
    Location:
    East Lansing, MI
    #11
    Looks like I missed the fact that he already tried that.

    It seems like your user folder is the default for Terminal, so that would make sense that his Library folder would be affected by this.

    If so, a simple chmod with the correct permissions on the folder could get him going again. I don't have access to my Mac right now, so I don't know what the "correct" permissions would be, but 744 might do the trick.

    Someone should check that on their machine and give him the EXACT chmod command to try...
     
  12. pooky macrumors 6502

    Joined:
    Jun 2, 2003
    #12
    Default in macos X is rwx------ for most of the user folder.

    So, fire up terminal, then copy and paste the following:

    cd ~
    chmod 700 *
    chmod 755 Public Sites

    That should do it. If it doesn't, run the ls command I posted above, and paste it here.
     
  13. aross99 macrumors 68000

    aross99

    Joined:
    Dec 17, 2006
    Location:
    East Lansing, MI
    #13
    I think he is going to needs quotes around Public sites or escape the space:

    chmod 755 "Public Sites"

    or something similar because of the space in the file name...

    :)
     
  14. merl1n macrumors 65816

    merl1n

    Joined:
    Mar 30, 2008
    Location:
    New Jersey, USA
    #14
    The correct format would be:

    chmod -R 755 ./Public\ Sites

    The -R means recursive and the backslash tells it to take the space character as literal. The ./ means the current directory.
     
  15. DLH macrumors member

    Joined:
    Jun 27, 2006
    #15
    No. pooky was correct. Public and Sites are two separate folders and both should be 755.

    Try this.

     
  16. aross99 macrumors 68000

    aross99

    Joined:
    Dec 17, 2006
    Location:
    East Lansing, MI
    #16
    My mistake. I hate not having a Mac at work...
     
  17. IniquityBliss thread starter macrumors newbie

    Joined:
    Jul 31, 2008
    #17
    TA DAAAA! It worked. I copy and pasted and it worked. Thank you so much.

    Here is my next question: I found 2 documents that are both preferences.cache - - do I delete these or leave them where they are?

    to top it all off: my itunes music is still there and all of my apps have gone back to how i last left them. i just need to re-do the dock and dashboard.

    you guys saved my life. thanks!
     
  18. pooky macrumors 6502

    Joined:
    Jun 2, 2003
    #18
    Not a problem. Take home message - if something tells you to do something in the Terminal, don't ever change it unless you know EXACTLY what the changes are going to be. If you do something and get an error, don't do the next step, start over.

    Not sure about the preferences.cache thing. Where are they located?
     
  19. aross99 macrumors 68000

    aross99

    Joined:
    Dec 17, 2006
    Location:
    East Lansing, MI
    #19
    Good luck on those 9 exams, now that your computer is back up and running!
     
  20. operator207 macrumors 6502

    Joined:
    Jul 24, 2007
    #20

Share This Page