iOS Confused with xcode version

rich1812

macrumors regular
Original poster
Oct 4, 2015
117
5
earth
Hello, all these xcode versions, swift versions keep my head spins. All I want is to learn some simple iOS programming, Which version of xcode with suit the best to program n old ipad mini, running the last iOS 9.3.5 it support, I can access its hardware such as camera... Thanks.
 
Last edited:

szymczyk

macrumors regular
Mar 5, 2006
172
9
Use the latest version of Xcode that will run on your Mac. The current version of Xcode is 10.1, which gives you the iOS 12 SDK. By using the iOS 12 SDK your app can take advantage of any features Apple added in iOS 12. 99.99% of the time you should use the latest iOS SDK.

To support iOS 9 set the deployment target of your project to iOS 9. You can change the deployment target by selecting your project from the left side of the project window.

SetiOSDeploymentTarget.png

The deployment target is the earliest version of iOS that can run the app. You have to be careful to use only code and frameworks that are available on iOS 9.

Summary: use the latest available iOS SDK and change the deployment target to support earlier iOS versions.
 
Comment

rich1812

macrumors regular
Original poster
Oct 4, 2015
117
5
earth
Thanks for the reply For the foreseeable future, I do not intend to upgrade from what I already have, which is the old iPad mini running ios 9.3.5. and I do not intend to develop any ios app to publish commercially, so I limit to target only ios 9.3.Can I develop ios 9. app on Xcode 10.1? Which swift version does it support?
When I upgrade to Majobe, It comes with Xcode 10.1, I set the target to ios 9.3, I got a lot of errors saying that certain functions only available on iso 10.1 or higher, but I can't find out what is the similar function to replace them.
 
Last edited:
Comment

szymczyk

macrumors regular
Mar 5, 2006
172
9
Yes, you can develop for iOS 9 with Xcode 10. Set the deployment target to iOS 9.

All Swift versions support iOS 9 and later. Unless you're using third-party libraries that were built with an older version of Swift, use the latest version of Swift, which is Swift 4.2 on Xcode 10.1.

There is no easy way to determine what functions you can use on iOS 9.
 
Comment

Crichton333

macrumors 6502
May 4, 2014
343
32
If you just want to "learn some simple iOS" why dont you run the simulator in Xcode and test your app ?

If you need the camera just set the target to iOS9 and run on iPad.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.