Confusion with Mail!

Discussion in 'OS X Mavericks (10.9)' started by Swordylove, Feb 9, 2014.

  1. Swordylove macrumors 6502a

    Swordylove

    Joined:
    Apr 23, 2012
    #1
    I use two accounts in Mail, one is my Yahoo account, and the other is Gmail. OS X 10.9.1.

    When I'm replying to an email from my Yahoo inbox, it gets sent from my Gmail account! At first I thought I forgot to select my Yahoo account in the "From:" field, but that would be stupid, because it should automatically be Yahoo since I'm replying an email in Yahoo inbox.

    When I was replying to an email from Yahoo inbox again, this time I made sure that I select my Yahoo address and Yahoo server next to it. It still got sent from my Gmail account! I clicked open the compose window again and looked at the "From" field and the server dropdown menu said "Yahoo! (Offline)". What does that mean? And I could choose my Yahoo address, but use Gmail server?

    Just now I intended to send a fresh email (not replying) from my Yahoo account and set the "From:" field to use my Yahoo address and Yahoo server (it didn't say "Offline"). After I clicked send, it got sent from Gmail! And when I opened the compose window it said "Yahoo! (Offline)". I tried signing in to the web version of my Yahoo mail, and the sent emails are there in the Sent folder! But I got auto-reply indicating that I sent the emails from Gmail!

    I'm very very confused here. What's really going on here? Is there a way to prevent Mail from automatically sending my email from Gmail if Yahoo is 'offline'? Please help. Thanks.
     
  2. LV426 macrumors 6502a

    Joined:
    Jan 22, 2013
    #2
    Make sure that you haven't accidentally set an account to an offline status. Mailbox | Online Status > Take ... Online/Offline

    You might want to also check in Mail | Preferences | Composing that "Send new messages from" is set to "Account of selected mailbox". Then, if you expand your inbox, click on an account, then hit the Compose button, the From field should automatically send the mail from the correct account.

    Can't help you why it might be saying "Yahoo (Offline)". If I turn WiFi off and expand my Inbox, my regular IMAP account has a lightning symbol (indicating it's offline), but iCloud email does not. And the "From" field never indicates "Offline".
     
  3. Swordylove thread starter macrumors 6502a

    Swordylove

    Joined:
    Apr 23, 2012
    #3
    Hi, thanks for your reply.

    I've checked all of that. The accounts are always online and I get emails in both accounts as usual. They would also have the lightning symbol if they're offline. The "Send new messages from" is also "Account of selected mailbox" and I had also checked the "From" field before sending the email.

    But at Preferences > Accounts, my Yahoo account says the "Outgoing Mail Server (SMTP):" is "Yahoo! (Offline)". How do I take it online? :confused:
     
  4. Macman45 macrumors demi-god

    Macman45

    Joined:
    Jul 29, 2011
    Location:
    Somewhere Back In The Long Ago
    #4
    I'd delete the Yahoo account. Backing up your mail first of course...then double check the outgoing server settings and recreate it. I've had issues where everything looks right, but for some reason things wouldn't work. You can also choose which account is the default. I actually stopped using Apples mail app a while ago in favour of Thunderbird. Free, and very flexible. There are versions for OSX and Windows if you are seeking an alternative.
     
  5. LV426 macrumors 6502a

    Joined:
    Jan 22, 2013
    #5
    What do you see when you click Mail | Accounts?

    Is it showing up as "Yahoo! (Offline)"?

    If so, this may be simply the account description (I guess it's possible that Yahoo was offline at the time when you set things up). You can edit the account description.
     
  6. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #6
  7. Swordylove thread starter macrumors 6502a

    Swordylove

    Joined:
    Apr 23, 2012
    #7
    I've tried deleting Yahoo account and adding back. Problem not solved. I might look for alternatives (thanks for the suggestion), but I still hope I can get this to work on Mail.


    No, it's just "Yahoo!". It's online, only the outgoing mail server is offline.


    I have no problem with Gmail so far. Thanks for the video, but it didn't help with my problem.
     

Share This Page