Connect iPhone 3GS & 4 to PPC iTunes?

Discussion in 'PowerPC Macs' started by Grunthaner, Mar 9, 2013.

  1. Grunthaner macrumors member

    Joined:
    Oct 5, 2009
    #1
    Is there a work around so I can connect either my iPhone 3GS (just used for music) or 4 (just got it and haven't set up to my phone line yet) to PPC iTunes? I called Verizon who called Apple and they said no for a PPC but that is because of an iTunes version right? Is there a work around?

    Does anybody have a chart link to tell me what connects to what regarding chips and version of OS iTunes and type of i-anything?

    I had a 2nd generation iPod Touch which connected to my PPC using Tiger until I lost it at the Airport.

    Is anyone connecting 3rd gen iTouch or iPhone to their PPC if so post your OS & ver iTunes :apple:

    This situation is the main reason I wanted to upgrade to an Intel iMac or Powerbook but I can't swing 1K for a new computer just to connect my music & apps.

    Thanks again,
    Linda
     
  2. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #2
    iOS 6 requires iTunes 10.7 which requires Snow Leopard
    iOS 5.1.1 will work on 10.6.3 which is the last version with support for Leopard
    The iPhone 3Gs and 4 can connect to a Leopard machine if they are running iOS 5.1.1 or below.
     
  3. Goftrey macrumors 68000

    Goftrey

    Joined:
    May 20, 2011
    Location:
    Wales, UK
  4. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #4
    It has beta support for iOS 6.0 in iTunes 10.6.3. It can be and is a bit buggy. Official iOS 6 support arrived in iTunes 10.7.
     
  5. Goftrey macrumors 68000

    Goftrey

    Joined:
    May 20, 2011
    Location:
    Wales, UK
    #5
    I was syncing my 3GS with iOS 6.0 (final release) with 10.6.3 on my G5 with no issues & didn't come across any bugs/problems. Just thought I'd point it out.
     
  6. Grunthaner thread starter macrumors member

    Joined:
    Oct 5, 2009
    #6
    Wow thanks guys, both Verizon and Apple said no I can't connect an iphone 3gs or 4 onto a PPC Mac.
    I should have asked here first.
    Thanks Linda
     
  7. skateny macrumors 6502

    skateny

    Joined:
    Jul 19, 2012
    Location:
    New York, NY
    #7
    All of them worked on PowerPCs until the iPhone 5, even with iOS 6. My 3GS works flawlessly with iOS 6.

    And yes, it's usually better to ask here first. Beyond this forum, there are many things you'd be told are impossible to do what, in fact, many people here have done.
     
  8. PowerPCMacMan macrumors 6502a

    PowerPCMacMan

    Joined:
    Jul 17, 2012
    Location:
    PowerPC land
    #8
    iPhone 4s

    Ok, I might be getting an iPhone 4s for the 1st time. My mac experience thus far has only been with OS X, OS 9, and Mac computers..

    So, If I am using 10.6.3 on my PowerBook G4 and my iPhone is a 4s and I want to get IOS 6.0, I shouldn't have a problem upgrading to IOS 6, right?
     
  9. skateny macrumors 6502

    skateny

    Joined:
    Jul 19, 2012
    Location:
    New York, NY
    #9
    Right as rain.
     
  10. Grunthaner thread starter macrumors member

    Joined:
    Oct 5, 2009
    #10
    Wow I would have gotten an iphone or a new touch a long time ago if Apple and Verizon didn't lie to me by saying they did not work on ppc.

    Hey which forum should I go to to post Powerbook g4 Titanium questions?
    Thanks again,
    Linda

     
  11. MisterKeeks macrumors 68000

    MisterKeeks

    Joined:
    Nov 15, 2012
    #11
    Same one you're in. :)
     

Share This Page