Connect iTouch to Macbook Pro - with proxy

Discussion in 'iPod touch' started by AceofGrace, Oct 22, 2010.

  1. AceofGrace macrumors newbie

    Joined:
    Oct 22, 2010
    #1
    Hey everyone, I have used the search feature and browsed for over an hour now but to no avail.
    The problem I have is this:

    My university requires us to connect to the internet via their Automatic Proxy (I have the URL). When opening the browser, we are sent to a website where we have to enter our individual username + password. (This works for both my Mbp + iTouch).

    Now my Mbp is plugged in via an ethernet cable and when opening the browser I am not sent to that site anymore, but just have to enter my username + password, all no problem.

    The problem I have is this: I want to connect my iTouch to the internet via my Mbp.
    I already configured it (system preferences --> sharing --> internet sharing)
    and was able to connect my iTouch to my Mbp without any problem.
    But I am still unable to open any webpage, the appstore won't load, etc.

    Does anyone have a potential fix to this? Something I should turn on, enter, etc.?

    Thank you very much in advance :)
     
  2. supermassive macrumors regular

    supermassive

    Joined:
    Sep 15, 2010
    #2
    Why would you want to connect through your MBP if it already works from your iPt directly?

    A proxy connection only supports the protocolls ftp, http and https. If you have an app which uses other protocols(like Mail smtp, pop3, imap), it won't work.
     
  3. AceofGrace thread starter macrumors newbie

    Joined:
    Oct 22, 2010
    #3
    Hey, thanks for the reply.
    The wireless signal is really bad in my room, meaning that it keeps dropping.

    So I want to use the same functions I currently am (app store, safari, games like tap resort, etc.) just via the mbp (I hope that makes sense)
     
  4. supermassive macrumors regular

    supermassive

    Joined:
    Sep 15, 2010
    #4
    Where do you enter your user + password? Into the browser?

    Did you turn on AirPort in the internet-sharing settings? Did you configure the advanced options like encryption?
     
  5. tactician1016 macrumors regular

    tactician1016

    Joined:
    Jan 17, 2010
    #5
    I have done the internet sharing thing. It... varies. Sometimes, the connection is perfect. Others... not at all. Restart the computer/iPod, maybe that will help. Otherwise... no idea.
    BTW: What university?
     
  6. AceofGrace thread starter macrumors newbie

    Joined:
    Oct 22, 2010
    #6
    It's just this drop down box (like when you're trying to access an ftp server)

    I did set encryption, but other than that I didn't see anything else that is supposed to be set?

    @tactician1016: I'm trying the restart of the iPod now, will update with news

    Edit: Nope, restarting iTouch didn't help :/
     
  7. supermassive macrumors regular

    supermassive

    Joined:
    Sep 15, 2010
    #7
    Try to ping google from your Mbp. Open up a Terminal and type: ping google.com

    I suppose that you'll get a request timeout, since you are still behind a proxy on the wired connection.

    In that case you will need to set up a transparent proxy on your Mbp. Which is not quite trivial.
     
  8. AceofGrace thread starter macrumors newbie

    Joined:
    Oct 22, 2010
    #8
    Pinging google.com from my mbp with terminal worked np (less than 12ms response time).
     
  9. supermassive macrumors regular

    supermassive

    Joined:
    Sep 15, 2010
    #9
    If you go to the network settings and look up the settings of ethernet (en0), what are the addresses of your Router and your DNS-Server?
     
  10. AceofGrace thread starter macrumors newbie

    Joined:
    Oct 22, 2010
    #10
    Followed your suggestion and deleted the numbers, ty.
     
  11. supermassive macrumors regular

    supermassive

    Joined:
    Sep 15, 2010
    #11
    It's ok(I suggest you delete those numbers all together), I just wanted to know if you get a router at all. So this is your gateway for the remaining protocols like pop3 and smtp. Otherwise your Mail wouldn't work.

    So since you have to use a proxy for http, http and ftp you still ned to configure a transparent proxy

    Here is a HowTo (http://discussions.apple.com/message.jspa?messageID=661489#661489) but it's ancient, don't know if it will work as described.

    Anyways if you want to try it, you can skip the steps 1-4. Just download the compiled squid, i.e. a .DMG

    Edit: Here is a graphical interface for squid: http://web.me.com/adg/squidman/index.html
    Maybe that will help a bit.

    I'm off to bed now, good luck!
     
  12. AceofGrace thread starter macrumors newbie

    Joined:
    Oct 22, 2010
    #12
    :X That really doesn't seem trivial...
    What exactly is the transparent proxy for? (I suppose this is the simplest way to do it? lol)
     
  13. supermassive macrumors regular

    supermassive

    Joined:
    Sep 15, 2010
    #13
    Well the Proxy redirects all http, https and ftp requests to the proxy of your university. It has to be done since those protocols can not be routed in your configuration.

    Another option would be to amplify the wifi with an intermediate access-point.
     
  14. AceofGrace thread starter macrumors newbie

    Joined:
    Oct 22, 2010
    #14
    Ah alright, looking into amplifying the signal might be the easiest then. I'm just worried I screw up something with the transparent proxy and end up not being able to use my internet at all...

    Thank you very much though supermassive, you've been a fantastic help :) I really appreciate it.
     

Share This Page