Connect MBA '12 to Xbox via USB Ethernet problem

Discussion in 'MacBook Air' started by 2bcool2, Jan 23, 2013.

  1. 2bcool2 macrumors regular

    Jan 31, 2008
    ive been trying this for a while now ... heres my back story,

    1st, yes i have internet sharing via usb ethernet from wifi on :)

    i want to use bt hotspot wifi from my mba to get xbox live via usb ethernet.

    researched the net when i had mbp running leopard, got it to work,
    replaced the mbp with 2012 mba ... bought non brand usb ethernet adapter, tried the same working settings on mac and xbox, didnt work ...

    i finally read that mountain lion works differently now , and that the ip etc stuff should be set to auto on xbox and dhcp on the mac ....

    i bought a 2012 iMac and connected the xbox via real ethernet on it,
    finally got it to work on that machine.

    i used the same settings using usb ethernet adapter on my mba but it cant see the network etc .. when i do manual on the mac and xbox, it sees the network fine, but fails on the next part, the internet...

    i donloaded the latest driver for the adapter 3.0.8 after reading a post somewhere .. they advised to use terminal command :

    kextstat | grep Ethernet

    its supposed to say :
    "63 0 0xffffff7f81505000 0x9000 0x9000 (3.8.0) "

    but mine says :
    " 98 0 0xffffff7f80ab4000 0x7000 0x7000 (1.0.0d1) <43 6 5 4 3 1>"

    doesnt mention 3.0.8

    so i was wondering if anyone had sucessfully got xbox live to work with mba with a usb adapter this way ?

    of any ideas why its seeing the network but not connecting to the internet ..

    i know it makes more sense to buy an apple one or even a thunderbolt adapter but i dont have the money for it

    and advice would help, there seems to be lots on the net about using ethernet but nothing about using a usb adapter

    thanks in advance

    love my mba
  2. xraydoc macrumors demi-god


    Oct 9, 2005
    If I'm reading things correctly, it sounds like your 3rd party USB-to-Ethernet adapter you're using on your MacBook Air isn't supported correctly.

    My advice, though you say you don't have the money, is to spend the $29 and buy an Apple-brand adapter.

    But perhaps someone else will have another suggestion.
  3. 2bcool2 thread starter macrumors regular

    Jan 31, 2008
    thanks for the advice, i in UK so it costs more than $29 here lol

    i have an idea, if i can get my mba to boot snow leopard from a usb 3 flash stick, ill try that, as my previous mbp on leopard worked, i know ML changed things up ... cheers ... any advice is helpful though probably not many people have my problem.

Share This Page