connect old G4 PwrBook to Linksys WRT54G

Discussion in 'Mac Basics and Help' started by ohTina, Apr 12, 2008.

  1. ohTina macrumors newbie

    Joined:
    Apr 12, 2008
    #1
    Is this possible?

    I'm still actually enjoying my old 667 MHz PwrBook G4 (OS 10.2.8), but since we got the Linksys WRT54G wireless router, it seems like my wireless days are behind me.

    Anyone had any luck getting this conglomeration to work?:rolleyes:

    Thx
     
  2. Eidorian macrumors Penryn

    Eidorian

    Joined:
    Mar 23, 2005
    Location:
    Indianapolis
    #2
    You just need to have an AirPort card on your TiBook.
     
  3. robanga macrumors 68000

    robanga

    Joined:
    Aug 25, 2007
    Location:
    Oregon
    #3
    I believe my sis in law, who was here last weekend had a G4 powerbook ( although i believe it was a 1.33 Ghz) and it connected fine with the WRT54G using my supplied wep key. What problems are you experiencing?
     
  4. robanga macrumors 68000

    robanga

    Joined:
    Aug 25, 2007
    Location:
    Oregon
    #4
    ah yes assuming you have an airport card. If you don't I just saw one for about $ 20 on ebay.
     
  5. ohTina thread starter macrumors newbie

    Joined:
    Apr 12, 2008
    #5
    The Aircard came with my tiBook. The little radiowaves are grayed out. It worked great back when I had the old airport spaceship thing, but that finally died. I've connected when I'm out at Panera's or something, but at home I try to connect, put in that horribly long WPA Shared Key, and I get nothing.

    Is there some old issue about the 802.11g not working with my older card?
     
  6. jodelli macrumors 65816

    jodelli

    Joined:
    Jan 6, 2008
    Location:
    Windsor, ON, Canada
    #6
    I have an iBook with an Airport card and 10.4.11 on it and it works with a WBR 1310 D-Link.
    Your G4 Power Book will work too so that's not the problem.

    Suggest that you use at least 10.3 or better yet 10.4 on that machine as 10.2.8 is not the best choice for networking. It is getting old after all.

    Example: I once had a Wallstreet with 10.2.8. It was far easier for me to network the drives between it and a Power Mac G4 using the 10.3 installed on the Power Mac than the other way around.
     
  7. ohTina thread starter macrumors newbie

    Joined:
    Apr 12, 2008
    #7
    Is it possible just to update the "firmware", or whatever it's called, of my internal air card? Has anyone be able to do this and have success?

    15" PowerBook G4
    667 MHz
    30GB harddrive / 512 memory
    OS 10.2.8 and 9.2
    still runs great.
     
  8. merl1n macrumors 65816

    merl1n

    Joined:
    Mar 30, 2008
    Location:
    New Jersey, USA
    #8
    On your Linksys, make sure that you have a/b/g enabled in the Wireless Setup as the Ti (I believe) Airport Card only supported "802.11b".

    You may also want to try to configure another location in the Network Pane of System Prefs, select Airport and Select your network. Click join and enter your WPA password. However using 10.2.x I don't remember if it actually supported WPA. You may have to change to WEP encryption.
     
  9. ohTina thread starter macrumors newbie

    Joined:
    Apr 12, 2008
    #9
    Thanks for the suggestion, I'll try that.
    I think you're on to something about the WEP vs. WPA. I don't think WPA worked with the original aircards.

    I also tried turning off my firewall, but that didn't work either. Any other ideas are welcome. Thanks!
     
  10. ohTina thread starter macrumors newbie

    Joined:
    Apr 12, 2008
    #10
    I discovered that if I disable security the little radio waves fill in full-power and I connect just great. But no security is not a good thing.

    Is there a setting that allows me to have some security and connectivity? WEP, WPA Personal, WPA Enterprise? I don't see a way to change the 801.11 to a/b/g or otherwise. If anyone has any other input on this, please do.
    -thx
     
  11. California macrumors 68040

    California

    Joined:
    Aug 21, 2004
    #11
    I happened to notice that there is a pci card (it will fit in the side of your Tibook in the pci slot on the left side) available on eBay that will blow your old airport card out of the water. You can then sell your old airport card for more money than you paid for this and also get yourself at least a Panther 10.3 disk for your old TIbook. That 10.2 jaguar sux.

    http://cgi.ebay.com/ws/eBayISAPI.dll?ViewItem&rd=1&item=320239380264&ssPageName=STRK:MEWA:IT&ih=011

    Oh and Tina, you need to bump up your memory on the Tibook. You need to max out your ram on the Tibook. You should buy two 512mb PC133 144 pin chips. Sell your two 256mb PC133 144 chips that you have in there, unless you happen to have only one 512mb chip and one empty ram slot (but I doubt it) I seem to recall that Tibook (I used to own that one) came with two 256mb chips installed. More ram, and get a faster hard drive and get that PCI card on eBay.
     
  12. merl1n macrumors 65816

    merl1n

    Joined:
    Mar 30, 2008
    Location:
    New Jersey, USA
    #12
    You can set up WEP.

    On the Linksys, go into Wireless -> Basic settings and set the mode for "Mixed". Then go to the Wireless Security Tab and set your mode to WEP128 bit. Enter a new paraphrase which will generate 3 hexadecimal keys. And chose which one will be used.

    On the mac in Network Settings for the Airport, you need to enter the "hexadecimal code" key you selected for the password. Note you may have to start the password with a dollar ($) sign followed by the key that was generated. This was for OSX 10.2.x. Try it first without the dollar sign and see if that works. If not try it with the leading $ sign.

    Note that if you change to WEP security, all other computers on your network using wireless must be changed as well.
     
  13. ohTina thread starter macrumors newbie

    Joined:
    Apr 12, 2008
    #13
    I'll try it today. Thanks for the suggestion, Merlin.

    California - that might be something I'll try eventually, too. Thanks for your input, as well!

    Wish me luck!
     
  14. ohTina thread starter macrumors newbie

    Joined:
    Apr 12, 2008
    #14
    These suggestions made so much sense, and yet no luck. If I turn off security setting, I hook up just fine. Security with WPA, WEP, $ signs, 128 bit passphases, nuthin'. "Airport cannot join this network due to an error." Any other ideas?
     
  15. velocityg4 macrumors 68040

    velocityg4

    Joined:
    Dec 19, 2004
    Location:
    Georgia
    #15
    Since you can connect to your network without security enabled on your router it sounds as though nothing is particularly wrong with you Airport Card nor Router. So you are able to browse the internet and see other computers on your network, assuming you use file/printer sharing, correct?

    Any ways in your Setup tab
    you have wireless set to mixed
    SSID and channel are set to something, say "default" and 6. and SSID broadcast is enabled

    For edit WEP settings start with 64bits since less inputting is required
    Do not bother with a passphrase for just go to key 1 and enter something easy like
    1234567890
    Make key 1 the default key
    leave all other keys blank
    hit the Apply button
    in the setup window hit apply again to be sure "unless you are already booted off the network"

    On your power book set up a new location for airport and try to connect you should be prompted to enter the security key, passphrase etc
    enter your passphrase
    1234567890

    If you are not prompted for a key then you powerbook is probably trying to use some non-existant or incorrect key to login. Though I can not recall how to do it in 10.2 you need to remove the key from your keychain file in Applications -> utilities. And in system preferences reset airport to its default settings. ie Use DHCP automatic, clear your preferred network list

    You should connect though. If this works then go back and change your routers security key this time choose 128bit and enter a random 26 digit hexadecimal key "0-9" "A-F" are allowed digits. There is no need for entering anything in keys 2-4 just leave them blank.

    If none of this works you could also try out MAC filtering though less secure it sets a list for your router of allowed computers and is supposed to keep invalid computers off of your network.

    Also you should download the latest firmware for your router from Linksys.com. As for your Airport card any firmware update should have been included with OS X's Software Update.
     
  16. ohTina thread starter macrumors newbie

    Joined:
    Apr 12, 2008
    #16
    Thanks Velocity. I'll try it. BTW, love that you're still running a Quadra. That's good stuff there! :apple:
     
  17. velocityg4 macrumors 68040

    velocityg4

    Joined:
    Dec 19, 2004
    Location:
    Georgia
    #17
    I don't use it too much. Mainly for Rescue! 2.0.5 the most awesome game ever and other old school games. Though I have been considering an :apple: IIgs for Odell Lake and Oregon Trail:D.
     

Share This Page