Connect to airport 'invalid password'

Discussion in 'Mac Accessories' started by drtpdee, Jan 5, 2008.

  1. drtpdee macrumors newbie

    Joined:
    Jan 5, 2008
    #1
    I have a network set up in which the primary access is via a cable modem connect to an AIrport Extreme. I also have an Airport Express connected as part of this network for Airtunes purposes. I typically connect wirelessly via a new iMac, no problems. I want my Powerbook G4 to connect as well (via its Airport Card). However, when I attempt to access the network and enter the password that I just created, it gives me an error stating 'invalid password'. What's going on? Also, when I set up my Airport Express, it wouldn't update the firmware despite saying that update was successful. It's 6.0 and won't go to 6.3:mad:
     
  2. Osarkon macrumors 68020

    Osarkon

    Joined:
    Aug 30, 2006
    Location:
    Wales
    #2
    Have you made sure the password you're inputting is in the right case? i.e. upper case or lower, or a combination of both, whichever you originally set it up with.
     
  3. drtpdee thread starter macrumors newbie

    Joined:
    Jan 5, 2008
  4. QuarterSwede macrumors G3

    QuarterSwede

    Joined:
    Oct 1, 2005
    Location:
    Colorado Springs, CO
    #4
    I've found that when there is a lot of interference from other wireless devices, especially other wireless routers, airport can't seem to connect well and when it does it asks for a password and then gives the "invalid password" response. I had that happen recently and the only thing that worked was changing the channel from 1 to 11 (everyone else around is on the default, 6). So I can only surmise that someone else who just moved in was interfering with my router because it happened all of a sudden (apartments suck for wireless connectivity, trust me).

    I don't know if that's your problem but just remember that it could be a symptom of another problem.
     
  5. Kristofer macrumors member

    Joined:
    May 17, 2007
    #5
    how do you "change the channel from 1 to 11"?
     
  6. Boogerhead macrumors newbie

    Joined:
    Feb 26, 2009
    #6
    Thanks for this thread. I had the exact same problem -- invalid password, when the computer was 4 physical feet and two thin sheets of drywall from a good router.

    Kristopher (or presumably anyone else who finds this through Google) -- the channel change is not on your Mac -- it's within your router itself. The way to do it will vary with the router. Most routers will have a Web page interface for administration. Look for something like Wireless settings.

    The "best" channel will depend on what your neighbors are using, but you might try 1, 6 or 11. My wife noticed her iBook connected faster than it had been, too, after we changed the channel -- interference will do that! =)
     
  7. Macuser60 macrumors newbie

    Joined:
    May 5, 2011
    #7
    Possible solution to "invalid password" problem on airport

    I had this exact same problem. After going through every suggestion here and elsewhere, and trying to reconfigure the network settings, nothing worked. Here is what did work for me:

    I deleted all the network profiles in my network settings. Then I did a factory reset on my AirPort Express (google it for instructions), and set up the airport with a new network as if it were brand new. Voila!
     
  8. rjphoto macrumors 6502a

    rjphoto

    Joined:
    Mar 7, 2005
    #8
    Wait! A G4 PowerBook...?

    What OS are you running?

    Which security profile, WEP, WPA or what is set up on the AirPort?

    You may only be able to use WEP depending on your PowerBook's OS.
     
  9. LDaniele macrumors newbie

    Joined:
    Oct 31, 2011
    Location:
    Northampton, MA USA
    #9
    Moving closer to Time Capsule solved "Invalid Password"

    All of a sudden, my wife's MacBook Pro lost its Internet connection. When I tried to log back in to our usual WPA2 wi-fi router, I kept getting "Invalid password" errors even though the password was correct. I could log on to a neighbor's unprotected wi-fi without problem. So then I tried putting the laptop right next to the Time Capsule / Router and "Voila!" it logged in just fine. So there might be something to this "interference" idea. I was able to then bring the laptop elsewhere in the house and not have a problem. Strange. Maybe it's just because it's Halloween! :)
     
  10. donavanm macrumors newbie

    Joined:
    Nov 23, 2011
    Location:
    FL
    #10
    Wireless Interference Causing "Invalid Password" Error on Wifi

    I have all Macs in my house and have never had a problem with my Internet connectivity until today. I'm a Technical Support Specialist and consider myself pretty computer savvy.. but I have to give props for this suggestion because the interference issue was exactly my problem although I still don't understand why this would give an "invalid password" error on the wifi connection.

    All my Apple computers were connecting wirelessly without a problem except for my MacBook Pro. I could not figure out why it was telling me the wifi password was incorrect when it had been working fine and all my other devices were obviously connected without a problem. I stumbled across this solution while researching the issue, and it hit me.. I recently installed a wireless TV tuner in my living room (which is the room I was in) that sends a wireless infrared signal to a receiver in my kitchen. I unplugged the wireless tuner and my Wifi immediately connected with no error.

    Thank you for the suggestion! :)
     
  11. pansitbijon macrumors newbie

    Joined:
    Nov 28, 2011
    #11
    Connect to Airport "Invalid Password" Problem Solved

    Netcomm Wireless Modem/Router Problem: Invalid Password or Connectivity Issue on Macbook Pro
    Indication of problem: PPP light isn’t on
    Indication that Modem/Router is working: Green steady lights on - Power, ADSL, PPP and flickering green light on WLAN and constant blinking on WPS

    Reset Modem/Router for 20 second
    Power off Modem/Router, Computer On
    Connect yellow (might be different) cable from router to Computer. Turn Modem/Router on.
    Open Internet Browser, type 192.168.1.1 Enter. You will be in Netcomm Website
    Enter username (admin) and password (admin). Enter
    Quick Start Tab: Enter ISP username and password. Click Connect

    To set up Wireless, Go to Wireless tab:
    Network Name (SSID) - Netcomm Wireless (You can personalize this but I left it as is)
    User Isolation - off
    Max User - 128
    Enabled - check
    Transmission Mode - 802.11b/g/n mixed mode
    Select Best Quality... - check
    Transmission Rate - Auto
    Multicast Rate - Auto
    Turbo Mode - Disabled
    Afterburner - Disabled
    Apply

    Still in Wireless tab, go to Security (under Basic setting)
    Select Wireless Network: Netcomm Wireless
    Wireless Security: WPA-PSK
    Data Encryption: TKIP
    Format: ASCII Characters
    Pre-Shared Key: Here, you can create a password of your choice. This is the password to connect to the Network
    WPA Group Rekey Interval: 0
    Apply

    Go to MAC settings
    Network
    Airport: Make sure it is turned on
    Find your Network Name (SSID)
    Apply
    Enter password/Pre-shared key. Voila! Hope this helps
     

Share This Page