Connect to itunes to use push notifications - serious problem

Discussion in 'Jailbreaks and iOS Hacks' started by Farfooz, Jun 14, 2009.

  1. Farfooz macrumors member


    Jan 20, 2009
    Hi im having a big big problem. when I open the aim beta test app or even when I opened the AP news app before, it said connect to iTunes to use push notifications and so I did but nothing happened. Every time I open the app it tells me to do so. I have not recieved a single push notification since any of the beta apps were offered for testing. This occurs every time I open the app it shows up as connect to iTunes to use push notifications. Also, I have badges and popups and sounds enabled for the app in notification settings in my settings. So that's not it either. And i restored my phone and still no luck. I am running an iPhone 1st Generation, anyone have an idea? Its really frustrating for i have tried multiple times to recieve push. I sign into my aim on my phone i have my account settings to sign out after 30 mins after i close the app and i have push on in aim and i picked the normal template. On top of that, i enabled it in my settings. I had the same problem in AP News app, the same pop-up. Why is push not working on my iphone? Im running iPhone 3.0 GM Seed and this problem was even there when i was running 3.0 Beta 5. I connect it to itunes and nothing happens. its weird. Anyone have a clue?

    [​IMG] [​IMG] [​IMG] [​IMG] [​IMG]
  2. AmpCoder macrumors 6502

    Mar 27, 2007
    I believe the e-mail said to contact Apple if you could not get push notifications working on either the AP New application or the AIM Beta application. Might be worth it to follow that link and contact them.
  3. Farfooz thread starter macrumors member


    Jan 20, 2009
    I did and its been a week and they haven't even bothered to reply and i have been updating it constantly.
  4. Menge macrumors 6502a


    Dec 22, 2008
    Farfooz, check your post on the devforums. It's a shame. I'm on the same boat, apparently.
  5. TheMBC macrumors 6502

    Jun 14, 2008
    Maybe it has something with the authorization of your iTunes or the actual Phone? Try deauthorizing and reauthorizing the iTunes software and then resyncing.
  6. Farfooz thread starter macrumors member


    Jan 20, 2009
    Hi, yeah i posted it on the devforums. They said it could be the cause of activating the iphone through other means, looks like im heading to get an AT&T sim today. But could this really be the issue? Of all features why would push do this? It doesnt add up. It's a good thing im in the states for a month just in time to upgrade to a iPhone 3G S back home half way across the world. If anyone has another solution please let me know ASAP. Thanks
  7. apoz macrumors newbie

    Feb 13, 2008
    I'm having the same problem with Tap Tap Revenge 2! :(:(
  8. abhinav76 macrumors newbie

    Jun 20, 2009
    Using iTunes push notifications

    Have figured out a way to use the jailbroken / unlocked iPhone for Push notifications.

    1. Update the OS on your iPhone to 3.0 by using the restore option in iTunes. Now the iPhone would ask for activation.

    2. Borrow the AT&T SIM card from soneone who is using a properly activated iPhone. Now insert that SIM card in your phone and activate it. Return the SIM card.

    3. Jailbreak your iPhone by using redsn0w or quickpwn.

    Now you will be able to run any Push Notification application.
  9. rogerssssss macrumors newbie

    Sep 29, 2008
    Dont lose your time trying to restore your devices. It seems Apple is more efficient in detecting JB'en devices. I just restored this way but about 5 minutes later push stopped working again. Either is Apple listing the devices eithe is it too easy for them to detect it the JB'en status...
    I would like the Dev-Team to find a way to stop Apple recognizing the JB on our devices...
  10. alex3yoyo macrumors newbie

    Aug 3, 2011

    My iPhone 4 was activated at the AT&T store, and I was running 4.3.3 jailbroken with redsn0w. I was having this same problem, the "Connect to itunes to use push notifications" popup popping up (duh). After some intensive Googling, I finally found a solution (and put it into easy steps that everyone can understand):

    1. Uninstall any tweaks or apps from Cydia that have anything to do with push notifications.
    2. In Cydia, tap "Manage", tap "Sources", tap "Edit", then tap the "+" button.
    3. Type in
    4. Tap "Add Source", and let Cydia do it's thing.
    5. Tap "Return to Cydia".
    6. Now tap "Search" and search for Push Doctor, and tap the first result.
    7. Tap "Install" and then "Confirm", and Cydia will start installing it.
    8. Now Tap "Return to Cydia"
    9. Enjoy your push notifications!!

Share This Page