Connect to Windows Shared Folders on Leopard

Discussion in 'macOS' started by tmoney468, Nov 21, 2007.

  1. tmoney468 macrumors 6502

    Joined:
    Mar 13, 2007
    #1
    Hi everyone, I've searched this topic before and couldn't find anything that worked for me so I decided to create my own thread. At home I have 2 PCs that both have shared folders on them. They are both in the same workgroup, home2, and I have already gone through the step up changing the workgroup to a new one (someone said in a thread that changing to a new workgroup fixed their problem).

    The only way I have been able to connect to the shared folders is to manually type in the IP address of the computer via the "Connect to Server" option in Finder. After I do this, the shared folders don't show up under "Shared", I have to manually click on the Macintosh HD icon and then press Apple-Up arrow to view the connected shared folders.

    Does anyone have any tips that I can try to get this thing working? It was so much easier in Tiger :(
     
  2. FBDiver macrumors newbie

    Joined:
    Mar 11, 2006
    Location:
    Pacific NW, USA
    #2
    Are your systems connected to a router? Are your PC's DNS setup correctly (using DHCP or static IP?) is your mac using DHCP (getting it's DNS from the router?) or static IP?

    Sounds like a DNS issue. My mac see's my PC's and my NAS no problem. Check settings in Sharing in system prefs.
     
  3. tmoney468 thread starter macrumors 6502

    Joined:
    Mar 13, 2007
    #3
    I have File Sharing Enabled in Sys Prefs, and everything on my home network is set up using DHCP. My PC downstairs is wired to the router, my PC in my room is wireless, as is my MBP. Funny thing, here at work when I click on "All" under the Shared tab in the Finder, I'm able to see all of the network shares here at work, so this leads me to believe that it's something with my home network.
     
  4. FBDiver macrumors newbie

    Joined:
    Mar 11, 2006
    Location:
    Pacific NW, USA
    #4
    Also check that the windows firewall is disabled. But if you can connect and ping the IP's but not the machine names, that is classic DNS problems. Go into the Advanced button in TCP/IP properties and then the DNS tab check to see if "Register this connection's addresses in DNS" is checked as well as "Use this connection's DNS suffix in DNS registration"
     
  5. tmoney468 thread starter macrumors 6502

    Joined:
    Mar 13, 2007
    #5
    I don't see any of those options in the Advanced section of the Network System Preferences...I have a TCP/IP tab that says "Configure IPv4: using DHCP and under the DNS tab, all I have is a listing of the DNS servers as well as Search Domains

    I was reading the Apple Help on my MBP and it said to find share Windows folders on your network, to go to Finder -> Connect to Server, and then select Browse...I did this and it still didn't find anything
     
  6. FBDiver macrumors newbie

    Joined:
    Mar 11, 2006
    Location:
    Pacific NW, USA
    #6
    Sorry... those setting are in the XP network settings (TCP/IP -> Properties)
     

Share This Page