Connect with HiLink modems

Discussion in 'OS X Yosemite (10.10)' started by blipmusic, Jul 25, 2014.

  1. blipmusic macrumors regular

    Joined:
    Feb 4, 2011
    #1
    Does anyone trying out Yosemite have any input on the self-starting HiLink 4G modems from Huawei? I have in some roundabout way gotten it to start but I'm not sure what part of the chain that's broken with Yosemite that works in Mavericks.

    My modem is a Huawei E3272 (might be exclusive to the operator Three/3 in Europe).

    The process is usually: connect to usb-slot, wait for the modem to mount and start the service on the on-board flash drive, register itself as a network interface and connect automatically.

    With Yosemite it mounts, then nothing.

    This is what I tried - dumb luck - that actually worked (not sure whether the kext part is needed, but that should contain the actual driver...?):

    1) Copy the app package "HiLink" to a place of your choice and show its contents.

    2) Show the contents of the package "mbbserviceSetup.pkg" in there.

    3) I assumed these two files were interesting:
    "Archive.pax.gz" (have contained Huawei drivers for manual install for modems I've used) and "AppleUSBCDCECMData.kext"

    4) Install the kext (someone who actually knows - not me- might want to chime in whether this is the correct procedure or not): copy the kext into "/System/Library/Extensions/" then follow the instructions here (the manual part further down on that page): http://www.macbreaker.com/2012/01/how-to-manually-install-kexts.html

    5) Unzip "Archive.pax.gz"

    6) Find the file "mbbservice" then run it form the terminal (cd to the actual folder it's in first): "sudo ./mbbservice"

    You'll have to manually start "mbbservice" each time you re-connect.

    Again, I don't know what part of the auto-connect chain is broken in Yosemite but the above seems to work. Maybe someone who is better informed than me can come up with a different way.

    EDIT: Now all of a sudden it connects automatically when re-connected to the usb-slot. Don't know if it's a consequence of the above but at least things seem to work.
     
  2. Brachaci macrumors newbie

    Brachaci

    Joined:
    Jul 27, 2014
    Location:
    Slovakia
    #2
    Works for HUAWEI E3251

    thx blipmusic that has worked for me as well...however I didn't find the kext file (maybe there are just some differences between yours E3272 and mine E3251 which is only HSPA+)so I just copy the package to my mac and run the mbbservice from terminal and the modem registered itself afterwards.

    thx again buddy! :) :apple: :)
     
  3. kalle123 macrumors newbie

    Joined:
    Jul 21, 2013
    Location:
    Sweden
    #3
    I just dropped by to say thanks!

    Although, the mbbservice seem to eat quite a lot of processor power. Around 10-30% idling all the time. But you solution is good enough until Huawei release a new update.:D
     
  4. rudivd macrumors newbie

    Joined:
    Feb 14, 2005
    #4
    works fine

    Hi,

    Thanks a lot. Trick also works great with E3531. Hope Huawei releases a version that works with 10.10 out of the box soonish. For now this will do.

    Thanks
    Rudi
     
  5. ArtMann420 macrumors newbie

    Joined:
    Oct 18, 2014
    #5
    I can't get it to work

    I've tried this, but I can't find the "AppleUSBCDCECMData.kext" file

    ----------

    I'm asking since i'm not that good with terminal and such
     
  6. keg25, Oct 19, 2014
    Last edited: Oct 19, 2014

    keg25 macrumors newbie

    Joined:
    Oct 19, 2014
    #6
    Solution

    Hi,

    after researching and trying out various workarounds for over an hour to get my Huawei HiLink modem working again under OS X Yosemite (10.10), installing this worked for me quick and easy:
    http://www74.zippyshare.com/v/54915703/file.html

    I have an MB Air an Huawei HiLink modem E303.

    Found the solution on this discussion board from Poland (translated link below, link to file is labelled "TO", i.e. "this" in Polish):
    https://translate.google.com/transl...demy-huawei-hilink-w-yosemite.html&edit-text=

    Not sure if the downloaded file is safe - anyone have input on this?

    Best

    keg
     
  7. rootuid macrumors newbie

    Joined:
    Nov 5, 2006
    #7
    I can confirm this works with a macbook Air and a E303 runnin Yosemite gm.

    I inspected the package , it APPEARS perfectly safe.

    These scripts don't do anything malicious, just set permissions for the driver files.
    postflight
    postinstall
    postupgrade
     
  8. ilsemolenaar macrumors newbie

    Joined:
    Oct 21, 2014
    #8
    I am not really into this stuff but since I am using an E3251 and installed Yosemite as well I am facing the same problem and trying to solve it.. :confused:
    Can you maybe explain to me which package you've copied (and where) and how I should run it from terminal?
    Thank you in advance for your help!
     
  9. sasper macrumors newbie

    Joined:
    Oct 21, 2014
    #9
    Just chiming in that I'm having the same problem with Mac OS X Yosemite 10.10 and my Huawei e3131 modem.

    In Mavericks, the modem was connected and would open up a network session, bringing me to local webpage (192.168.0.1) where I would connect to the network.

    I currently have no network entries for the Huawei modem, and running the installer that is mounted by the USB stick had no effect. I've also gone through the links provided in this discussion to no avail.

    Cheers.
     
  10. Kevinattheabbey macrumors newbie

    Joined:
    Oct 22, 2014
    #10
    It works!!!

    Thank you for that information keg25. I downloaded the zippy share link onto my 2009 macbook with huawei E3231 dongle and it is now working exactly as it did previously. Pity Apple and Huawei can't be as efficient as these guys who sort these problems out.
     
  11. MacAdi macrumors newbie

    Joined:
    Oct 23, 2014
    #12
    Thanks!

    Thanks to keg25, solution worked perfectly for my E3272. Big up!

     
  12. mrblueeye macrumors newbie

    Joined:
    Oct 23, 2014
    #13
    What to do?

    Hi KEG25, i downloaded the Zip, but what have i to do with the files? Copying to stick oder to system? Where exactly? Thank you for help!
     
  13. Kevinattheabbey macrumors newbie

    Joined:
    Oct 22, 2014
    #14
    Installing

    I removed the dongle and double clicked the installer symbol and it done it all automatically. Restarted mac and that was it. Good luck!
     
  14. GFirmin macrumors newbie

    Joined:
    Oct 26, 2014
    #15
    Thanks!

    Thanks to keg25! This worked for me too! I'm also using a Huawei E303.
     
  15. Malph macrumors newbie

    Joined:
    Oct 26, 2014
    #16
    No luck with E3331

    Not sure if I am doing something wrong, but I can't get my E3331 to work.

    I have downloaded the link and installed the little program then...

    - Tried to start the modem by running Library/Startupitems/Mobilebrserv but nothing happens

    - Tried to restart my Macbook... nothing happens, I don't even get the HiLink icon anymore which I got before I installed the Mobilebrserv!

    My Macbook doesn't seem to recognize my modem anymore now. Anyone knows a solution?
     
  16. cloudman1978 macrumors newbie

    Joined:
    Oct 27, 2014
    #17
    Hello,
    Each time where I download this file to make my E3131 work, the systems tells me that this file is not usebable and the unique option that it gives is to send the file to the trash.

    http://www74.zippyshare.com/v/54915703/file.html

    Could you help with this problem please?

    Regards
     
  17. adm1968 macrumors newbie

    Joined:
    Oct 31, 2014
    #18
    Perfect!
    I just downloaded the zip file, extracted, and installed
    I then plugged the modem back in, and voilà. Working like a charm :)

    Many thanks, Keg25 :)
     
  18. jacekb1 macrumors newbie

    Joined:
    Oct 12, 2014
    Location:
    Poland
    #19
    This is my entry for Polish forum and solution works perfectly. Is it safe? For me, and as you can see in others nothing happens so I assume so.

    Sorry for my english...
     
  19. amori23 macrumors newbie

    Joined:
    Nov 7, 2014
    #20
    works perfect thank you very much and thanks for the original author.
     
  20. bugout macrumors 6502a

    Joined:
    May 11, 2008
    Location:
    is everything!
    #21
    No luck for me. i have the 3272.. It connects, but I have no internet access.
     
  21. figaro80 macrumors newbie

    Joined:
    Dec 9, 2014
    #22
    Some success but restricted speed

    The zip file worked well for me and my E3231 device but I seem to be experiencing much slower speeds than are available in my area (full reception with same network on my phone and displayed via the webpage too).

    Has anyone else experienced this?
     
  22. lisnsooz macrumors newbie

    Joined:
    Dec 18, 2014
  23. nicksoper macrumors member

    nicksoper

    Joined:
    Mar 6, 2006
    Location:
    Cape Town
    #24
    This zippy file worked for me with the Huawei E3272 on Yosemite 10.10 - THANKS!

     
  24. Hemantha macrumors newbie

    Joined:
    Mar 25, 2015
    #25
    Huawei E3531 dongle issue

    Hi All,

    I have updated the firmware in my Huawei E3531 dongle, and the installation was successful. But now it doesn't detect from my laptop. I checked with mobile doctor as well but it can't solve the issue. what could be the issue, please can anyone help me.
     

Share This Page