Connected to wifi but no internet

risk235

macrumors member
Original poster
Oct 17, 2011
81
6
I have a late 2012 Mac mini with a static ip address that keeps losing its connection even though it shows that I'm still connected to my wifi network. I can't access the internet though I am able to still access the router's settings page at 192.168.10.1 If I wait like 5 minutes or so my connection resumes like normal. The other work around is if I turn off my wifi on my Mac then back on and it starts working again. Then maybe 30 min will pass before it does it again and no internet. I have tried numerous solutions from other threads with no success. I have included a picture of my terminal where I lose my internet connection around 6:22
 

Attachments

risk235

macrumors member
Original poster
Oct 17, 2011
81
6
What type of internet connection, dialup, cable, dsl?
Its cable. I have a Trendnet single channel N router. All my other devices such as my iPhone, iPad, laptop, PS3, etc. connect fine. Its only my Mac that I'm having problems with. Right now I'm typing this from my Mac mini. It's working fine right now. But later on while I'm using it I'm sure I will lose my data connection even though it show I'm connected to my router.
 

Josebueno777

macrumors newbie
Mar 6, 2018
2
0
Santiago, Dominican Rep.
Same thing is starting to happen to my iMac late 2012. Restart and works fine, but it loses internet connection suddenly while still connected to wi fi. All other devices, Mac Book Air, iPhone and Ipad all connected to Internet. Is there a fix for this?
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.