Connected to wifi but no internet

Discussion in 'OS X Mavericks (10.9)' started by risk235, Nov 28, 2013.

  1. risk235 macrumors member

    Joined:
    Oct 17, 2011
    #1
    I have a late 2012 Mac mini with a static ip address that keeps losing its connection even though it shows that I'm still connected to my wifi network. I can't access the internet though I am able to still access the router's settings page at 192.168.10.1 If I wait like 5 minutes or so my connection resumes like normal. The other work around is if I turn off my wifi on my Mac then back on and it starts working again. Then maybe 30 min will pass before it does it again and no internet. I have tried numerous solutions from other threads with no success. I have included a picture of my terminal where I lose my internet connection around 6:22
     

    Attached Files:

  2. Partron22 macrumors 68020

    Partron22

    Joined:
    Apr 13, 2011
    Location:
    Yes
    #2
    What type of internet connection, dialup, cable, dsl?
     
  3. risk235 thread starter macrumors member

    Joined:
    Oct 17, 2011
    #3
    Its cable. I have a Trendnet single channel N router. All my other devices such as my iPhone, iPad, laptop, PS3, etc. connect fine. Its only my Mac that I'm having problems with. Right now I'm typing this from my Mac mini. It's working fine right now. But later on while I'm using it I'm sure I will lose my data connection even though it show I'm connected to my router.
     
  4. Josebueno777 macrumors newbie

    Josebueno777

    Joined:
    Mar 6, 2018
    Location:
    Santiago, Dominican Rep.
    #4
    Same thing is starting to happen to my iMac late 2012. Restart and works fine, but it loses internet connection suddenly while still connected to wi fi. All other devices, Mac Book Air, iPhone and Ipad all connected to Internet. Is there a fix for this?
     

Share This Page