Connected to Wifi but no internet

Discussion in 'MacBook Air' started by LaninaZA, Mar 31, 2018.

  1. LaninaZA macrumors newbie

    Joined:
    Mar 31, 2018
    #1
    hi everyone, I'm new her and wondering if someone can please help me.

    When I am at work out at sea we use the wifi on board for internet connections. I have never had any issues with getting online with any of my devices, as well as my MacBook Air. I arrived back here two days ago and I have no issues connecting to the network and Internet with my mobile phone and my iPad but for some or other reason I can get onto the network with my Mac but get no internet access, but if I start up in recovery mode I can access the Internet. Here are a few things I have tried to no avail.

    • Rebooted computer numerous times
    • Forgotten network and rebooted
    • Tried using various Internet browsers like Mozilla, Safari and chrome
    • Disconnected my VPN
    • Started in recovery mode and once in safari I can access the Internet.
    • Tried to connect through my seagate wifi hard drive as a hotspot.
    I am not the most clued up on computers so not sure what else to try, I would really appreciate any help from anyone. I originally thought that the server might have blocked my I.P address after using a VPN in the past but if it was blocked then how do I access it in recovery mode then?
     
  2. bfresh_8 macrumors newbie

    Joined:
    Mar 30, 2018
    #2
    try finding out what the DNS entries are on the boat using DHCP (system preferences->network>select WIFI->advanced->DNS>. You could always try hard coding your DHCP address/DNS servers and see if that makes a difference. OPEN TERMINAL and try to PING your default gateway, DNS servers. If you can't PING either - bigger problems.
     
  3. LaninaZA thread starter macrumors newbie

    Joined:
    Mar 31, 2018
    #3
    Thanks for the reply but this is all a bit Greek to me unfortunately.
     
  4. Mrbobb macrumors 601

    Joined:
    Aug 27, 2012
    #4
    If this used to work and all of a sudden doesn't, well somebody did something. Speak to person who setup this WIFI/LAN. If unable to look under the hood yourself well I guess u gotta call somebody/professionals.
     
  5. saulinpa macrumors 6502a

    Joined:
    Jun 15, 2008
    #5
    I've found that deleting "Wi-Fi" in System Preferences-Network fixes a lot of problems. Then you can set wireless up from scratch.

    Next to try would be to remove the VPN software as some has been known to corrupt TCP/IP even when not running.
     

Share This Page