connectify.me and atv2

Discussion in 'Apple TV and Home Theater' started by IrmaN, Dec 14, 2010.

  1. IrmaN macrumors newbie

    Joined:
    Oct 12, 2009
    #1
    Hi
    i live in denmark and have a win 7 machine that has connectify me installed.

    i have set up a vpn connection on the machine and am amble to watch movies at netflix when the connection is established.

    Therefore i want to use connectify.me to share the VPN connection with my atv2 so it also can stream netflix content --> so a set up conectify.me by choosing the vpn connection to be shared.

    On atv2 it is possible for me to play movies from itunes with the connectify.me shared vpn but netflix does not work :-( it says that there is no connection with server....

    dores anyone have any good suggestions as to what i may have done wrong?
     
  2. p17blo macrumors newbie

    Joined:
    Apr 27, 2009
    #2
    I don't know your exact setup but the most usual reason for onward VPN issues in this type of setup is due to IP address ranges in use.

    Generally when you create a VPN connection the IP address of your device is added to the list of traffic to be VPN'd. But anything connecting to your VPN'd device will carry a different IP address. Unless the VPN'd device is natting your other traffic (ie making them look as though they appear as your VPN'd device) AND directing these to the VPN tunnel, not simply your Ethernet port or similar then you will have an issue.

    I probably haven't explained myself very well here, it is a complex issue.

    The easier things to check are to ensure that any option to route ALL traffic to VPN is chosen (you might not actually want this but select it if it is an option to see if that helps with your other devices). If you have any options as the 'local' traffic IP addresses, make sure that ALL of your devices attempting to use the VPN are included.

    Lastly, I would highly recommend a hardware VPN client for multiple devices. Something like a Draytek router has one built in, but these are not cheap, trying googling hardware vpn client to see if there is anything better for your needs.

    Paul
     
  3. IrmaN thread starter macrumors newbie

    Joined:
    Oct 12, 2009
    #3
    well i guess that explains it. The VPN ip address on the computer is 199.48.xx.xx while the atv2 gets adress in the 192.168.1.xx range --> so i guess that is why it does not work.

    I have tried with the VPN hardware (a dd-wrt router) but that i could not make work either

    so i guess i will have to wait that apple upgrades airplay so it can do netfllix too
     

Share This Page