Connecting a Samsung CLP325W

Discussion in 'Mac Accessories' started by lampoon22, Dec 7, 2011.

  1. lampoon22 macrumors newbie

    Joined:
    Dec 7, 2011
    #1
    I'm running both a iMac and a Macbook wirelessly on Netgear router.

    My Samsung CLP325W printer arrived yesterday, I inserted the installation disc and followed the instructions and was printing within ten minutes. The printer is connected via an ethernet cable straight to my router. Life was good.

    But... we had a power cut at home today and it lasted about an hour. I tried to print something when the electricity returned but the printer wasn't having any of it.

    I've tried everything (which for a man of my computer knowledge wasn't a lot) to try and get everything back working again but to no avail. I've removed the printer and drivers, tried to reinstall the software but when I try to print, the following happens:

    The print queue box appears and it says 'printing document xx%', then it changes to 'Connected to printer', then to 'spooling job, xx% complete'. This is where it remains until it then throws up the message 'Remote host did not accept data file (32)'

    As I stated earlier, my computer knowledge isn;t up to much so if anyone can help but using simple instructions, I'd greatly appreciate it.

    Could it be something to do with IP addresses?

    Thanks in advance.
     
  2. skorpien macrumors 68020

    Joined:
    Jan 14, 2008
    #2
    It could very well be the IP address. After the power outage, your printer could have acquired a different IP address than before causing the issue. I'd begin with simply restarting everything in the chain. First unplug your modem, router and printer. Then plug in your modem and wait for it to finish booting. Then the router. And finally, the printer (and maybe reboot the computer for good measure). After that's done, try removing and adding the printer from your Printer Preferences.
     
  3. lampoon22 thread starter macrumors newbie

    Joined:
    Dec 7, 2011
    #3
    I'm going to try that tonight.

    Should my IP addresses for the printer and the router match?

    I've written everything down now and the things that are the same are the subnet masks and the default gateway on the printer and router ip address.

    Sorry for the 'noobness'
     
  4. skorpien macrumors 68020

    Joined:
    Jan 14, 2008
    #4
    We're all noobs at one point in time, so no worries.

    Default gateway and subnet masks should be the same, but the IP addresses must be different. Let's assume your router is 192.168.1.1 (or something similar) and it assigns IP addresses to devices connected to it starting with the first three groups of numbers (192.168.1.XXX). Usually this is handled dynamically as different devices join, each getting an IP address that's unique and sequentially larger (162,168.1.2, 192.168.1.3, etc.). If that's the case, it's possible that your printer had one IP address before the outage and another after everything came back on, after which computer may not know how to communciate with it as it is looking for the printer's old IP address. But when it is removed and re-added in the Printer Preferences pane, your computer will have the new IP address and should be able to communicate with it without issues. Hopefully that's all it is as this should resolve it.
     
  5. lampoon22 thread starter macrumors newbie

    Joined:
    Dec 7, 2011
    #5
    The IP address for the router is 192.168.0.1 and the printer is 192.168.0.8

    Does this look unusual? Should I change the printer to 0.2 or doesn't it matter?

    In the settings for the router, it also says it gets the IP address dynamically, should it be static?
     
  6. skorpien macrumors 68020

    Joined:
    Jan 14, 2008
    #6
    I was just using those numbers as examples. There is nothing wrong with the IP address of your printer or router.

    You should keep the settings of the router the same. That is for acquiring an external IP address from your ISP and should remain as is. What I'm talking about is the IP address of your printer.

    Within the printer settings (either in the software or using the control panel on your printer), you should be able to set how the printer gets its IP address from the router. Right now it's probably set to dynamic, but you can give it a static IP address. Make sure it begins with 192.168.0.XXX and give it any number between 2 and 255 and outside of the router's DHCP range*.

    *Usually routers have a specific range of IP addresses that they assign to clients (DHCP range). This may be in your wireless settings of your router or in its documentation. The IP address you assign to the printer should be outside of this range to avoid the router accidentally assigning the same IP address to another device while the printer is off.

    Seeing as how your router is assigning your printer a lower IP address, it would probably be safest to assign static IP addresses beginning at the higher end of the spectrum and working down. So for example, your printer can be 192.168.0.255 as this is at the opposite end and probably outside of the range.

    Alternatively, some routers have the ability to reserve specific IP addresses for specific devices (DHCP Reservation). This is done within the router's settings and will require that you know the wireless MAC address of the device. Once you know that, you can enter the device's MAC address and the IP you'd like to assign to it and your router will give that IP address to that device and that device only.

    Sorry if this is all wordy or confusing. I tend to get a bit verbose when explaining. If anything, you can always just try what's been suggested and do that whenever this situation arises.
     
  7. lampoon22 thread starter macrumors newbie

    Joined:
    Dec 7, 2011
    #7
    The printer finally printed yesterday after completely switching everything off and on again and doing the exact same thing I thought I'd been doing the other times I tried to get it to work. It did take a long time to print though and was 'spooling' for ages. Tried to print again later and nothing again - how frustrating!

    I've now solve the problem. I've connected it to the iMac with a USB. I've admitted defeat.

    Another thing, which may or may not be related, was that when I tried to use my iMac and Macbook at the same time to browse the net, a message appeared to say that I had another device using the same IP address. I changed the one on my iMac manually and the problem seems to be solved. Could this be connected to the problem trying to print through my router too?

    I did try to change the printer IP to .255 but it didn't seem to make any difference.

    I think I need 'easy to follow' instructions.
     

Share This Page