Connecting FStream app to 3G network

Discussion in 'iPhone Tips, Help and Troubleshooting' started by BigEddieM37, Jan 2, 2010.

  1. BigEddieM37 macrumors newbie

    Joined:
    Jan 2, 2010
    #1
    I downloaded the FSTREAM app from the app store onto my 3GS so that I could listen to some audio streams of interest (from Live365 in particular). I'm a new user to the iPhone and I'm enjoying the device very much.

    But I'm frustrated with some inconsistent 3G ntwk connection behaviour with this particular app. Initially the app worked well and the URL's of the audio streams I was interested in listening to worked just fine. It's a nice app. The app was able to connect to ATT's 3G network no problem. However after about 8 or 9 minutes or so the app would just stop and display DISCONNECTED. Attempts to reconnect failed. Then for no apparent reason when I launched the app about 4 hours later it worked fine. But, again, I was able to listen for about 15 minutes (via 3G connectivity) and it quit. Same thing also happened while driving around in my car listening to audio streams via this app. ~10 minutes and that's it.

    I then changed my iPhone network settings to WiFi=ON (to connect to my FIOS wireless router) and, to my surprise, the FSTREAM app worked fine. Not with AT&T 3G connectivity however. Connection to the internet using the 3G ntwrk works well with other apps such as google, yahoo or safari connecting reliably through 3G. But not the fstream app. So I would think that the iPhone itself can be ruled out as a culprit. (???)

    I called both AT&T customer care and Apple Care support and both, though very happy to help me, said that they have NO idea what the problem could be. I do have the unlimited data package. And I've tried some different settings with the fstream app to no avail. Has anyone else experienced this type of 3G network connection problem with this particular app or does anyone have any suggestions? The website for the app really offers no help on a network connection issue other than "check with your network provider". (I did that.) I'm stumped on this one. Suggestions appreciated.
    Thanks.
    Eddie
     
  2. BigEddieM37 thread starter macrumors newbie

    Joined:
    Jan 2, 2010
    #2
    Over the period of time since I posted my last inquiry and with the latest OS on my 3GS the FStream application has worked quite well. Some intermittent disconnects are experienced from time to time while connected to the 3G cellular network. But it works and it is what it is. I did notice something interesting however about launching the application and getting it to actually connect when I first open the app, which I was hoping someone could explain to me.

    When I launch the application, usually when my iPhone has been idle from accessing the internet for some time, the FStream app opens up fine and I notice that up in the top right-hand corner of the screen there is the familiar RUN/PAUSE "triangle" button. IF that particular button is grayed out and NOT appearing in the color white then the application will NOT connect to any audio stream which I may select.

    However if I close FStream, open Safari, access a web page and establish an internet connection, when I return to and re-open FStream the app the RUN/STOP icon is now white and the app works just fine. So essentially it seems like FStream relies on an internet pipe that was already and recently opened from some other app as it can't setup and establish the internet connection by itself. Is this normal behavior? Or is there some FStream setting that needs to be specifically set to "auto-connect"? This is something that caught me by surprise when I first started using the app. But it works fine. I'm curious as to why it behaves like this. Would anyone know why?
    Thanks.
    Ed
     

Share This Page