Connecting Macbook pro to Sony Bravia TV

drtanz

macrumors member
Original poster
Sep 27, 2012
58
0
I am connecting my Macbook Pro 13 june 2012 model to a Sony Bravia LP 32 inch tv. The picture has a heavy purple colour cast, anyone know what the problem may be?

Display settings is on the pixel dimensions 1360 x 768 when this happens. However when I switch the setting to 720p the colours are ok. The thing is that the text is more clear to read on 1360px x 768px so I would like to use that setting.
 

rrm998

macrumors regular
Jun 15, 2012
197
4
Houston, TX USA
Not being familiar with the ports on the Sony, how are you connecting your Mac to it? VGA? HDMI? I wonder if the set is going into some kind of PC mode when getting video at sub HD resolution. And that mode isn't calibrated correctly.

The input resolution can cause different behaviors. I have an HDMI device that shows badly over saturated when inputing at 1080p60 but is perfect at 1080p24. I must admit I've not tried to figure out if it's a device or TV issue. I'm happy with it set to 1080p24.
 

drtanz

macrumors member
Original poster
Sep 27, 2012
58
0
Im connecting via HDMI. I have a converter from thunderbolt to HDMI. The converter works fine I also tried a Dell XPS 15 with the same setup and it outputs the picture normally.
 

T5BRICK

macrumors G3
Aug 3, 2006
8,102
2,095
Oregon
I know this isn't really a solution, but I'd probably skip the cables and adapters and just use an AppleTV and Airplay.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.