Connecting OSX over VPN to Samba Shares

Discussion in 'macOS' started by tegansnyder, Nov 14, 2008.

  1. tegansnyder macrumors newbie

    Joined:
    Nov 14, 2008
    #1
    Hello Everyone,

    I'm using Viscosity to connect to our VPN at work. I'm able to establish a connection just fine, but I have a few issues.

    It appears to be assigning me a local IP address; however, I'm unable to ping the gateway. I'm also unable to ping the local Samba domain.

    Any ideas?
     
  2. Jiff Lemon macrumors member

    Joined:
    Apr 8, 2008
    #2
    Your local IP range isn't the as same as the remote one?
     
  3. trainguy77 macrumors 68040

    Joined:
    Nov 13, 2003
    #3
    That would be my first guess as well. If your local IP that your computer has is the same range as the one on the other network VPN won't work.
     
  4. tegansnyder thread starter macrumors newbie

    Joined:
    Nov 14, 2008
    #4
    My local IP range is 192.168.1.x
    The remote IP range is 192.168.9.x

    They are in different subnets but technically still in the same class... maybe I should try changing my local IP range?
     
  5. trainguy77 macrumors 68040

    Joined:
    Nov 13, 2003
    #5
    nope your fine. When connecting are you getting a .9.x address assigned as well?
     
  6. trainguy77 macrumors 68040

    Joined:
    Nov 13, 2003
    #6
    I have never used viscosity but i would look at the network tab and see if you have a Route setup. If not either make one or click the send all traffic over VPN and see if that helps.
     
  7. tegansnyder thread starter macrumors newbie

    Joined:
    Nov 14, 2008
    #7
    Ok... I changed my local IP range to 10.10.10.x

    I just connected to the VPN. Viscosity shows that is assigned me the following:

    Client IP: 192.168.9.203
    Server IP: 64.122.73.226

    I'm unable to ping the server IP or the gateway. Could this be a firewall issue? We are running IPTables rules on the Linux machine that handles the VPN and samba.
     
  8. trainguy77 macrumors 68040

    Joined:
    Nov 13, 2003
    #8
    What number are you pinging? a .9.x address i am assuming?
     
  9. belvdr macrumors 601

    Joined:
    Aug 15, 2005
    #9
    Is that the entire remote IP range at work? Are you sure there are no other subnets, and the subnet mask for work systems is 255.255.255.0? I should also add that you could be assigned a 192.168.1.x IP just for VPN clients. To be sure, I'd change your local subnet to something different, say 172.31.1.0/24.
     
  10. tegansnyder thread starter macrumors newbie

    Joined:
    Nov 14, 2008
    #10
    I'm pinging the gateway 192.168.9.4. It is the gateway, firewall, openvpn server, and samba server. It's remote IP is 64.122.73.226.

    I can't ping either the local IP or the remote IP.
    It shows I'm connected and gives me a local IP.

    Incidentally I kept the VPN connected on my laptop then I went to other computer and ssh'd into the gateway machine. From terminal on the gateway machine I can't ping the local IP it handed out to my laptop.

    I think it's a firewall issue.
     
  11. tegansnyder thread starter macrumors newbie

    Joined:
    Nov 14, 2008
    #11
    I put myself in that subnet and it didn't make a difference.
     
  12. belvdr macrumors 601

    Joined:
    Aug 15, 2005
    #12
    So let me get this straight, you're on a 172.31.1.x subnet now, with a default gateway of 172.31.1.y.

    You connect to your VPN server at work, and it gives you a 172.31.1.x IP now? Sounds like your OpenVPN server isn't configured correctly.
     
  13. tegansnyder thread starter macrumors newbie

    Joined:
    Nov 14, 2008
    #13
    No...

    My home pc is on the 172.31.1.x subnet with a gateway of 172.31.1.1

    When I connect to the VPN it gives me a 192.168.9.x address.
     
  14. tegansnyder thread starter macrumors newbie

    Joined:
    Nov 14, 2008
    #14
    I would also like to mention that I have a windows pc. And on my windows pc I'm able to VPN into work and ping the gateway just fine.

    So I think it may be some settings in the vpn client Viscosity on OSX.
     
  15. tegansnyder thread starter macrumors newbie

    Joined:
    Nov 14, 2008
    #15
    Ok - I can now ping the gateway just fine. I just compared my openvpn configuration file on my windows machine to the one on the osx machine.

    I just need to be able to access the samba shares. Any advice? I can't seem to ping the domain.
     
  16. belvdr macrumors 601

    Joined:
    Aug 15, 2005
    #16
    Ok, so now we know you have Windows machine that works. Is it able to locate machines by hostname and domain name? If so, then it appears your client config isn't picking up the internal DNS servers on OS X.
     
  17. tegansnyder thread starter macrumors newbie

    Joined:
    Nov 14, 2008
    #17
    Resolved

    I got it to work....in case anybody else has this problem here is how I did it:

    I had to manually connect to the samba shares by doing the following:

    Finder - Go - Connect to Server...
    Type in smb://workgroup;username@hostname/sharename

    Thanks to everyone that helped I really appreciate it.
     

Share This Page