Connecting to a wireless network

Discussion in 'Mac Basics and Help' started by finnerNJ, Sep 2, 2007.

  1. finnerNJ macrumors newbie

    Joined:
    Sep 2, 2007
    #1
    Interesting situation here. We moved, and replicated our network in the new house. With our old service (Cox), my iBook could connect to the network no problem. With our new service (Comcast), the iBook can see the network but cannot get an IP address. Here's the set up:

    Service from Comcast to a Motorola Surfboard modem
    Modem to a Netgear MR814v2 router
    Network is set up with 48 bit WEP security, same as at our old house

    I can connect to the internet fine if I am connected directly to the router using an ethernet cable. I can see the network but can't get an IP address if I try to access it wirelessly. We did manage to get it to connect once or twice by reseting the router (unplugging it, letting it sit for 5 minutes, then plugging it back in), but the minute the iBook went to sleep or I shut it down, it lost the ability to get an IP address again. The Dell laptop that is also on this network has no problem connecting wirelessly, just the iBook.

    Any suggestions on how to get my iBook onto our network?
     
  2. yg17 macrumors G5

    yg17

    Joined:
    Aug 1, 2004
    Location:
    St. Louis, MO
    #2
    1. Get rid of WEP ASAP and use WPA. WEP is so insecure and can be cracked extremely easily.

    2. If the iBook can't connect, and the Dell can, is it right next to the iBook or closer to the router? Only thing I can think of right now is maybe there's something about your new place that's messing with the wireless signal, either a source of interference or building construction. But if they're right next to each other, and one can connect and the other can't, that's probably not the case :\

    Also, is the iBook connecting and not getting an IP, or just not connecting? (Does the Airport icon in the menubar have a few of the line thingys filled in or is it completely grey?)
     
  3. finnerNJ thread starter macrumors newbie

    Joined:
    Sep 2, 2007
    #3
    1) Yes, we will be switching to WPA, once we get some sort of connectivity on the iBook. One problem at a time...

    2) The Dell can connect from anywhere in the house, including when they are in the same room with the router. The iBook airport icon claims full connectivity, but when I look in network settings, it has a self-assigned IP address, and can't talk to the network at all.
     
  4. yg17 macrumors G5

    yg17

    Joined:
    Aug 1, 2004
    Location:
    St. Louis, MO
    #4
    Wirelessly posted (HTC_P4350 Mozilla/4.0 (compatible; MSIE 6.0; Windows CE; IEMobile 6.12))

    if you go into the network settings for the airport connection, is it configured to use DHCP?

    Also, I hope you're not using the default SSID of your router (probably "netgear"), are you? if you are, its possible that there may be another wifi network in range with the same SSID and ypur iBook is connecting to that

    Other than that, Im not really sure what's wrong. I've never had the self assigned problem since I use static IPs on my network.
     
  5. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #5
    The Netgear is the same router you used before, only with a different (?) cable modem and a different ISP?

    Was the Dell notebook in the setup before?

    Are you sure the Dell notebook is using DHCP and is not forcing an IP address selection? If one of the computers is defining its own IP and the other is using DHCP, it can fail because the IP can already be taken.
     
  6. finnerNJ thread starter macrumors newbie

    Joined:
    Sep 2, 2007
    #6
    The modem and the router are exactly the same as in the previous set up, just the service provider is different. The Dell notebook was present in the previous set up as well. Both laptops are set up to obtain their IP addresses using DHCP. The network is not named 'netgear' and we've changed the channel to one that does not appear to be in use by our neighbors. I have checked the airport card while on vacation and was able to wirelessly connect to hotel networks, so the problem is not in the airport card, as far as I know.
     
  7. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #7
    Okay, gotcha. Are any two devices (iBook or not) able to connect to the new network at the same time?

    Sometimes there is a setting in the cable modem that has to do with whether it will allow a router to distribute addresses under it (I think Comcast and others once upon a time used this to prevent people from home networking without paying them a fee). So I think the next step is to log into the modem and see if you can find it and change it.
     
  8. finnerNJ thread starter macrumors newbie

    Joined:
    Sep 2, 2007
    #8
    We only have two devices trying to access the network wirelessly. We also have two PCs and a print server connected directly to the router via ethernet - which was also the case in the old set up. They have no trouble connecting.

    So how do you go about logging into the modem itself to check out settings?
     
  9. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #9
    If you have more than one device accessing the network, whether wireless or not, it's probably not the issue. (For what it's worth, you typically access the modem by finding the IP address the router sees on its WAN port and typing it into your browser URL bar).

    Hmmm...puzzler. You tried the diagnostic assistant thing built into OS X already, right? It couldn't find a way to fix it?
     
  10. finnerNJ thread starter macrumors newbie

    Joined:
    Sep 2, 2007
    #10
    Yeah, the diagnostic assistant couldn't figure out what was wrong either. This is driving me nuts!
     
  11. sbluetruck macrumors regular

    sbluetruck

    Joined:
    Jul 25, 2007
    Location:
    Wisconsin der hey
    #11
    MAC address filtering and the iBook isn't in the list?
     
  12. finnerNJ thread starter macrumors newbie

    Joined:
    Sep 2, 2007
    #12
    Nope. Never got MAC address filtering working in the previous house, so it's not turned on here. It seems to come down to the only real difference, besides location, is the ISP. Has anyone had any success setting up a mixed PC/Mac, wireless/wired network with Comcast?
     
  13. yg17 macrumors G5

    yg17

    Joined:
    Aug 1, 2004
    Location:
    St. Louis, MO
    #13
    I'm stumped here, but I can guarantee you that the ISP isn't making a difference. Ethernet is a standard, and your ISP doesn't care what's plugged into that modem, whether it's a Mac, PC, linux box, router, whatever.
     
  14. Aperture macrumors 68000

    Aperture

    Joined:
    Mar 19, 2006
    Location:
    PA
    #14
    I agree Comcast isn't making a difference. Though, I have heard the rumors they make it harder to setup wireless networks. To prove it false, I have a mixed OS network with both wireless and wired traffic on Comcast - all going through a Netgear router.
     
  15. yg17 macrumors G5

    yg17

    Joined:
    Aug 1, 2004
    Location:
    St. Louis, MO
    #15
    And they're just that....rumors. Comcast doesn't care, in fact, they have no idea, what you have plugged into your modem.
     
  16. mbpcron macrumors member

    mbpcron

    Joined:
    Jun 23, 2007
    Location:
    Richmond, VA
    #16
    ibook, macbook wireless problems

    There are a number of threads on this problem. Most resolutions I've seen indicated an auto-upgrade of OSX or the wireless driver was done and the owner forgot about it. The problems were traced to the Apple software driver being incompatiable with the wireless router. The new provider was probably a coincedence.
    When I bought my MBP in June with 10.4.8 I've refused any upgrades and haven't had a problem. 10.4.9 and 10.4.10 seem to be roll of the dice for issues.
    Saw at least one thread on how to rollback the software, somewhere. T
     

Share This Page