Connecting to external USB drive connected to PC

Discussion in 'Mac Accessories' started by krko, Jul 6, 2007.

  1. krko macrumors newbie

    Joined:
    Jul 6, 2007
    #1
    Hello all,

    I've been searching the internet and this forum for hours already but couldn't find the solution to my problem.
    I have a local network with PCs and Macs. I have an external USB2 and Firewire 400, 500GB FAT32 formatted Western Digital drive. The drive is connected via USB to one of the PCs in the network. All I want to do is access this drive from my Macbook. When I try to connect to it I get "error code -41" and I cannot connect. I can access other shares and mount them easily as well as other drives on the very same PC. It's not a firewall issue and I've set the share on this external drive just as I did with other shares which I can access normally. All computers, both PCs and Macs belong to the same workgroup if it's of any relevance. I'm running Win XP Pro SP2 on PCs and Tiger 10.4.10 on my Macs.
    I'd appreciate your help on this issue greatly.

    Thanks,
    krko
     
  2. krko thread starter macrumors newbie

    Joined:
    Jul 6, 2007
    #2
    BTW, I connected another external USB drive I have to the very same PC and managed to connect to it from my Macbook. It seems I get this error only when using the WD MyBook Premium.

    krko
     
  3. krko thread starter macrumors newbie

    Joined:
    Jul 6, 2007
    #3
    Hello all,

    I solved the problem! I tried connecting to that drive from another PC and I got the following error:
    "Not enough server storage is available to process this command"

    This pointed me to this Microsoft article which was apparently the right way to solve the problem:
    http://support.microsoft.com/default.aspx?scid=kb;en-us;177078

    Here's the text from the above article copied:

    Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

    To resolve this behavior, increase the IRPStackSize value in the registry:
    1. Click Start, and then click Run.
    2. Type regedit, and then click OK.
    3. Navigate to the following key:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanServer\Parameters
    4. In the right pane, double-click the IRPStackSize value.

    NOTE: If the IRPStackSize value does not already exist, use the following procedure to create it:
    a. In the Parameters folder of the registry, right-click the right pane.
    b. Point to New, and then click DWord Value.
    c. Type IRPStackSize.

    IMPORTANT: Type "IRPStackSize" exactly as it is displayed because the value name is case-sensitive.
    5. Double click it and change the Base to decimal.
    6. In the Value Data box, type a value that is larger than the value that is listed.

    If you created the IRPStackSize value using the procedure described in step 4, the default value is 15. It is recommended that you increase the value by 3. Therefore, if the previous value was 11, type 14, and then click OK.
    7. Close the Registry Editor.
    8. Restart the computer.

    I changed the value of IRPStackSize to 21 in my case and that did the trick. Max value btw, for Win 2K/XP is 50.

    All works just fine now. I can connect to the drive from all my PCs and Macs.

    Me happy :)

    Thank you all anyway,
    krko
     

Share This Page